Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Bug Monodevelop did not work

Discussion in 'Linux Editor' started by t_w, Sep 9, 2015.

  1. t_w

    t_w

    Joined:
    Aug 4, 2015
    Posts:
    55
    use the monodevelop(build-in), cannot open the file correctly by doublie clicking on editor. Even open the cs file handfully, then you can not use suggestion.

    0903 build unity and 4.0.1 built in monodevelop
    ubuntu 14.04
     
  2. t_w

    t_w

    Joined:
    Aug 4, 2015
    Posts:
    55
    I found the solution.
    Delete the space in the project folder (just the spaces in the folder name)
     
  3. rootPL

    rootPL

    Joined:
    Sep 5, 2015
    Posts:
    14
    I have similar problem but in my case there is no spaces in any folder

    Can some suggest what should I try ?
    I went to
    /opt/Unity/MonoDevelop/bin$
    and tried to run it manually there but it didn't run

    I have an error:
    ./monodevelop: line 21: exec: mono: not found
     
  4. rootPL

    rootPL

    Joined:
    Sep 5, 2015
    Posts:
    14
    ok silly me:

    Ubuntu 14.04 64-bit
    sudo apt-get install mono-complete
     
    Ryuuguu likes this.
  5. rootPL

    rootPL

    Joined:
    Sep 5, 2015
    Posts:
    14
    I still have some error with loading gnome-sharp add-on in monodevelop but it seems that everything is working fine without it
     
  6. t_w

    t_w

    Joined:
    Aug 4, 2015
    Posts:
    55
    Sorry, I have not met this error.

    But have you install mono?
     
  7. lassade

    lassade

    Joined:
    Jan 27, 2013
    Posts:
    74
    @rootPL i have the same problem here in my Ubuntu 14.04.1, do you have a solution?

    My solution was installing monodevelop by
    Code (CSharp):
    1. $ sudo apt-get install monodevelop
     
    Last edited: Sep 23, 2015
    i_bolt_it likes this.
  8. AZeroEight

    AZeroEight

    Joined:
    Sep 29, 2015
    Posts:
    7
    Installing monodevelop on Gentoo helps as well: "emerge monodevelop" as this will pull in all dependencies but you will end up with another (in my case older) instance of monodevelop.
     
  9. Sabun

    Sabun

    Joined:
    Nov 13, 2012
    Posts:
    12
    I too cannot use Monodevelop that comes with Unity 5 (this is the latest version Unity 5.1.0f3+2015091501).

    I have to first install Monodevelop from the Ubuntu Software Center, then install Unity 5 for it to work (I presume it's using my system's Monodevelop and not the one that comes with Unity).

    The issue now is that double clicking a script from inside the Unity editor will open Monodevelop, but not the file itself. I have to use Monodevelop's manual Open function to find the script and open it.

    With every script I try to open from within Unity, it will open a new Monodevelop instance as well. This is not the intended experience I'm sure.

    Running on Ubuntu 15.04 64bit.
     
  10. CyRaid

    CyRaid

    Joined:
    Mar 31, 2015
    Posts:
    99
    Here are some things that I've found will block your usage with Monodevelop and Unity. 1) If you have a git repository with your Project, you won't be able to edit any files.. As if all of the files are "read-only". Delete the ".git" folder and you can continue. 2) If you have another project you've opened up with Unity/Monodevelop, and for some reason it's not loading, it will always error until you clear the 'recent solutions' list. Because it will (on-load) try and open the last project, THEN open the current project (weird I know).
     
  11. masterchop

    masterchop

    Joined:
    Oct 9, 2015
    Posts:
    39
    This is my situation, similar to Sabun, Monodevelope did not work from Unity until i install the standalone.
    After doing that, the build-in worked just fine and now it opens.

    The problem is that when you click the script not all the time opens it and sometimes i lose the auto complete.
    This is very useful if you are new to the object you are working on.
     
  12. i_bolt_it

    i_bolt_it

    Joined:
    Oct 17, 2015
    Posts:
    1
    The problem is that when I double click on script every time opens new Monodevelop. How can i fix it?

    Sorry for my English it's not my mother language (

    The solve is
    Code (CSharp):
    1. $ sudo apt-get install monodevelop

    ty @lassade
     
    Last edited: Oct 18, 2015
  13. KarlGG

    KarlGG

    Joined:
    Nov 4, 2014
    Posts:
    33
    I second (or thirteenth) this, Installed Unity on a clean Ubuntu (Mate) install (14.10, then fully updated) that didn't have MonoDevelop installed yet. Ubuntu MonoDevelop wouldn't work until I installed the standard one, and then it won't load files on clicking, and autocomplete is not working.
     
  14. elthlan

    elthlan

    Joined:
    Oct 18, 2015
    Posts:
    1

    Same problem. My project folder name does not have spaces.

    Running Elementary Luna (built on Ubuntu 12.04 64bit)

    Regardless, no other work stopping issues so thanks Unity for this version!
     
    Last edited: Oct 21, 2015
  15. fabioj

    fabioj

    Joined:
    Jan 9, 2016
    Posts:
    7
    Hi..!

    I think i found the problem causing the built-in monodevelop editor doesn't work out-of-the-box. I looked into /opt/Unity/MonoDevelop/bin/monodevelop (the shell script file that run the editor) and i found in the line 14 a call for a program named realpath (SCRIPT_PATH="`realpath $0`"). Then i tried to run the program manually in a terminal window, but the program it is not installed.

    I installed realpath with a
    Code (CSharp):
    1. sudo apt-get install realpath
    command on Ubuntu 14.04 and the built-in editor launched just fine. That would solve the issue, i think.

    edit:
    Making some research i found that are other methods for obtain the same result as realpath gived to the SCRIPT_PATH variable without the need of install the realpath. (I have not really tested this solution)

    eg.
    Code (CSharp):
    1. echo $(cd $(dirname "$0") && pwd -P)/$(basename "$0")
    source: http://stackoverflow.com/questions/5265702/how-to-get-full-path-of-a-file

    I hope this info can help someone. :)
     
    Last edited: Apr 20, 2016
    GreedyVox, Dsiak, t_w and 1 other person like this.
  16. scotopicone

    scotopicone

    Joined:
    Apr 29, 2016
    Posts:
    1
    fabioj likes this.
  17. t_w

    t_w

    Joined:
    Aug 4, 2015
    Posts:
    55
    Thanks, it is fixed after update unity.
     
    fabioj likes this.
  18. Dsiak

    Dsiak

    Joined:
    Oct 11, 2015
    Posts:
    11
    tylerecouture and fabioj like this.
  19. GreedyVox

    GreedyVox

    Joined:
    Nov 18, 2015
    Posts:
    21
    Thank you, Fixed me too!
     
    fabioj likes this.
  20. tylerecouture

    tylerecouture

    Joined:
    Oct 17, 2015
    Posts:
    6
    Thank you! Worked on Linux Mint 17.3 and Unity 5.4.0p1
     
    fabioj likes this.
  21. leodluz

    leodluz

    Joined:
    Jul 12, 2016
    Posts:
    17
    Me install realpath or use this echo in script did not work. but I found another solution.
    1) open the script file with gedit in sudo: sudo gedit /opt/Unity/MonoDevelop/bin/monodevelop

    2) change the script like this in the picture, specifying the directory of the raw and direct way monodevelop and save.

    (line: EXE_DIR="/opt/Unity/MonoDevelop/bin/")
    3) Specify the unity in preferences> external script editor> browse> select the INICIALIZATION SCRIPT of monodevelop, Attention: not the .exe.

    Done.

    Obs: Unity 5.5b5

    fabioj, thanks to you my Linux development environment was made possible!


    Linux users do not give up!
     
    Last edited: Oct 18, 2016
    fabioj and mosaic_school like this.
  22. thackerybrown

    thackerybrown

    Joined:
    May 28, 2017
    Posts:
    1
    This worked like a charm for me on 5.6.1 on Ubuntu 14.04. Thanks!
     
  23. leodluz

    leodluz

    Joined:
    Jul 12, 2016
    Posts:
    17
  24. Gamevara

    Gamevara

    Joined:
    Jun 7, 2015
    Posts:
    12
    Thanks for the tips.

    None of them didn't work directly, but combine some of the tricks I make it work. This is what I did:
    Install monodevelop (sudo apt-get install monodevelop)
    In Unity preferences browse to /usr/bin/monodevelop
    and that's it.

    I have freshly installed Mint 18.1 and Unity2017.1.0f1
     
  25. Zagaz

    Zagaz

    Joined:
    Dec 30, 2015
    Posts:
    52
    To install Monodevelop on UBUNTU (Linux):

    Install Unity3D First.

    Then install Monodevelop.

    1) sudo apt-get update

    2) sudo apt-get install mono-complete

    3) sudo apt-get install eferenceassemblies-pcl

    4) sudo apt-get install ca-certificates-mono

    After that

    Go to Prefs > External Tools > Open monodevelop in>

    Browse:

    Computer/opt/Unity/MonoDevelop/bin/ MonoDevelop.exe


    It worked for me!!!

    Shalom!
     
  26. JTMartins

    JTMartins

    Joined:
    Aug 9, 2017
    Posts:
    1
    In my case, I've installed the Monodevelop from monodevelop website and not from a software center, as usualy we get older versions.

    In this situation we end up with a flatpack package, which is a kind of sandbox where monodevelop will run.

    To link monodevelop editor with Unity I changed the monodevelop script in /opt/unity/MonoDevelop/bin to

    Code (CSharp):
    1. #this script should be in $PREFIX/bin
    2. MONO_EXEC="flatpak run com.xamarin.MonoDevelop"
    3. #MONO_EXEC="exec -a monodevelop mono"
    4. #EXE_DIR="/opt/Unity/Monodevelop/bin/"
    5. #SCRIPT_PATH="`realpath $0`"
    6. #EXE_DIR="`dirname ${SCRIPT_PATH}`"
    this solution is NOT 100% functional as we do not have autocomplete, but I can open the Solution scripts directly from Unity, edit & save them.
     
    Last edited: Aug 10, 2017
  27. donbright

    donbright

    Joined:
    May 3, 2015
    Posts:
    1
    Thanks, I confirm this works on Ubuntu 16.04 and Unity 2017.3.f1
     
    Zagaz likes this.
unityunity