Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Model not displaying animation

Discussion in 'Animation' started by Farel, Dec 23, 2014.

  1. Farel

    Farel

    Joined:
    Dec 23, 2014
    Posts:
    3
    I have put models into Unity, but none play any animations, ever. A friend even supplied me with a model to make sure it works, but it doesn't. I added a screenshot. Can anyone please help me?
     

    Attached Files:

  2. Farel

    Farel

    Joined:
    Dec 23, 2014
    Posts:
    3
    I have a little news update. I tried to create a brand new project and just put the model in there as first, but there are still the same issues....
     

    Attached Files:

  3. medhue

    medhue

    Joined:
    Aug 24, 2014
    Posts:
    176
    Your model has no Animator Controller. Just rightclick/create in your project, and create an Animator Controller. Then, select your object, and drag that Animator Controller into the right slot. Then, select the Animator Controller and drag in an animation from the object.

    At the very end of this video, I show this process. Advance the video to about 26:37

     
    Farel likes this.
  4. Farel

    Farel

    Joined:
    Dec 23, 2014
    Posts:
    3
    Thank you, although honestly upon closer introspective, I also kept forgetting to click "Apply" when doing changes to the model in the project window.
     
  5. theANMATOR2b

    theANMATOR2b

    Joined:
    Jul 12, 2014
    Posts:
    7,790
    Doh! I hate that button! It always gets me too!