Search Unity

  1. Unity 2020.1 has been released.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Missing Post Processing Behaviour after installing Post Processing Stack

Discussion in 'Package Manager' started by apiotuch, Jan 12, 2019.

  1. apiotuch

    apiotuch

    Joined:
    Oct 8, 2009
    Posts:
    42
    I know this is a common problem, and I do not know why this is happening or how to fix it. I have Unity 2018.3.0f2 and When I install Post Processing stack via the Package Manager for version 2.1.2, the behaviour script is missing. I can create a profile and play with the stack, but I cannot attach the component to the camera. It does not appear in the list.

    Does anyone know how to fix this issue?

    upload_2019-1-12_3-42-40.png
     
    SolAgurken likes this.
  2. apiotuch

    apiotuch

    Joined:
    Oct 8, 2009
    Posts:
    42
    Ok, so after looking elsewhere, I learned that the behaviour is no longer needed. Layer and Volume components are used. Unity needs to update their manual since it makes no mention of this change. This video explains how to do it properly.
     
  3. LocalsOnlyCoop

    LocalsOnlyCoop

    Joined:
    Mar 8, 2019
    Posts:
    5
    Thanks for this post. They really need to update the documentation.
     
    Thate likes this.
  4. andreadoria

    andreadoria

    Joined:
    Feb 5, 2014
    Posts:
    3
    Nazar-Pallaev and Thate like this.
  5. Thate

    Thate

    Joined:
    May 13, 2019
    Posts:
    1
    Muchas gracias, busque esto por casi 4 horas, de verdad muchas gracias
     
  6. MacKieC

    MacKieC

    Joined:
    Oct 30, 2018
    Posts:
    4
    I had the same problem, thank you!
     
  7. Audacity_Child

    Audacity_Child

    Joined:
    Feb 18, 2020
    Posts:
    4
    I tried EVERYTHING until i found this video and followed it step by step, with a few previous steps..
    1.) Delete any post processing attached to your cam or anything else.
    2.) Fully uninstall Post Processing in the Package Manager.
    3.) Re-Install Post Processing(I Installed Lightweight because I was told it had something to do with it but I don't believe that to be true after seeing this video... just throwing it out there just in-case tho.
    4.)

    (new V2 version allows you to set all to a specific layer and attach both Layer and then Volume directly to your camera)
    5.) HAVE FUN!
     
unityunity