Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Minimum API level 19?

Discussion in 'Android' started by GuruGurra, Dec 5, 2019.

  1. GuruGurra

    GuruGurra

    Joined:
    Jan 18, 2018
    Posts:
    33
    Using Unity 2019.3.0f1, I cannot set minimum API level lower than Android 4.4 (API 19) which according to Google Play means that 10% of my users cannot get the new version. If I remember correctly I previously had API Level 14 as minimum.

    Is there something wrong or is there by some reason a restriction in 2019.3.0f1?
     
  2. Aurimas-Cernius

    Aurimas-Cernius

    Unity Technologies

    Joined:
    Jul 31, 2013
    Posts:
    2,655
    We increase minimum API level from time to time based on usage statistics.
    We rely on our analytics I believe, that is the actual installs of made with Unity games.
     
  3. GuruGurra

    GuruGurra

    Joined:
    Jan 18, 2018
    Posts:
    33
    By technical reasons or just because you think you "should"? Is there anything I can do to include earlier levels?
     
  4. Aurimas-Cernius

    Aurimas-Cernius

    Unity Technologies

    Joined:
    Jul 31, 2013
    Posts:
    2,655
    Technical. We have separate code paths depending on versions as well as limitations.
    If you want to target earlier levels, the only thing you can do is to use older version of Unity.
     
  5. Haze-Games

    Haze-Games

    Joined:
    Mar 1, 2015
    Posts:
    90
    I understand how this makes sense and it's additional work to keep older versions of minimum API. I also understand the fact that you may have less active users < API 19.

    However, there is something I'd like to point out, that is an issue for us right now:
    - Some markets still require to upload APKs with minimum API level 17 (especially markets in Asia, etc.)
    - We are right now having various crashes and bugs that are fixed only from 2020.1. However, if and when we upgrade from 2019.1.14f1, we won't be able to update on these stores because of the API 17 requirement

    Is it possible to do the following:
    - Have a branch of the project upgraded to 2020.1 (when released) for Google Play
    - Have a separate branch for these stores that require API 17, using 2019.1.14f1, and continue building with these crashes that are not fixed (better than stopping all updates)
    - Edit the main project and scenes in 2020.1, and merge them into the the 2019.1.14f1 project branch

    Will scenes and prefabs edited and saved in 2020.1 be backwards-compatible with 2019.1.14f1?

    If the above is not possible, it means that any user targeting other than Google Play will need to either:
    1) Use older versions of Unity (2019.1.14f1 is the latest functional version for us) to be able to build for all stores
    or
    2) Use latest versions of Unity to enjoy all the new bugfixes, but dropping support for various other stores other than Google Play

    Thank you,
    Charles
     
  6. aleksandrk

    aleksandrk

    Unity Technologies

    Joined:
    Jul 3, 2017
    Posts:
    1,658
    @Haze-Games Bug fixes usually get backported to earlier versions. If it's fixed on 2020.1, this means 2019.3 should get it as well.
    No, backwards compatibility is not guaranteed. If you really need this to work, you're better off editing you stuff in Unity 2019.x and then opening a copy in 2020.1.
     
  7. Haze-Games

    Haze-Games

    Joined:
    Mar 1, 2015
    Posts:
    90
    Thanks for your reply. Yes, I imagine 2019.3 will have back ported fixes, but it still cannot build API 17, so we need to stay on 2019.1 for some stores for that reason.

    The editor after 2019.1 is unusable for us due to baking failing with light probes in the scene and other issues (all fixed in 2020.1 which is great).

    I think the only solution for now is to stay on 2019.1 to build for these other stores, and use 2020.x soon for stores which accept API 19 as minimum, but never edit scenes and stuff on 2020 as you said, and only make changes in 2019.1 until these stores decide to switch to API 19 as minimum too.

    Thanks for the info.
     
  8. Tomas1856

    Tomas1856

    Unity Technologies

    Joined:
    Sep 21, 2012
    Posts:
    2,311
    Out of curiosity, why didn't you choose to use LTS version of Unity like 2018. Since as per https://unity3d.com/unity/qa/lts-releases only LTS builds receive bug fixes for period of two years.
     
  9. Haze-Games

    Haze-Games

    Joined:
    Mar 1, 2015
    Posts:
    90
    To be honest, don't remember exactly why we didn't choose to switch to LTS. I think I did try it out, and still had issues, so was waiting for fixes on tech. We require the GPU PLM and consoles support, and maybe at the time it was getting improved mainly on tech stream, and we were using LWRP, but then switched back to default, in tech stream.
    We still don't use URP due to Camera Stacking (now available, yay!), Shadowmask requirement and point lights shadows.

    I'll have a look at LTS and see if it's a better solution for us and if GPU PLM works well with default rendering, Mixed lighting in Shadowmask + Light Probes. If it does, might be best to switch to this instead. Thank you!
     
unityunity