Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

Question Microphone Input Doesn't Work 1st APK Run

Discussion in 'VR' started by Verne33, May 10, 2024.

  1. Verne33

    Verne33

    Joined:
    Apr 12, 2020
    Posts:
    36
    Edit: The issue was due to Voice SDK losing access to the mic during the permission window phase. See: https://developer.oculus.com/documentation/unity/voice-sdk-known-issues/

    ---------

    Has anyone dealt with Microphone permissions on Quest?

    For some reason the microphone input never works on the first run of the app after permissions is granted. It works fine from the 2nd onwards.

    It's the Unity microphone class and I've tried calling into the class at various points in my app to trigger the permission screen at different times, and so far nothing has worked.

    he permission screen does come up, and I've confirmed I have the correct device name even on the first run. I've also tried manually entering into the android manifest prior to build time. But it never seems to actually record input until the 2nd run.

    Any advice would be much appreciated!
     
    Last edited: May 10, 2024