Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Bug Meta Quest update 57 breaks OpenVR development

Discussion in 'VR' started by cecarlsen, Sep 18, 2023.

  1. cecarlsen

    cecarlsen

    Joined:
    Jun 30, 2006
    Posts:
    856
    The Unity Editor suddenly started crashing consistently when hitting Play after my Quest 2 automatically updated to Meta Quest v 57. I am using OpenVR to be able to develop for PCVR both on Quest and Pico.

    Are anyone else experiencing this?
     
  2. PsiconLab

    PsiconLab

    Joined:
    Oct 9, 2017
    Posts:
    27
    I've had this update 57 wipe out some content being rendered properly for Quest (worked fine in Editor - nothing in Quest). Wasn't an OpenVR issue though but this update seems to have caused problems.
     
  3. glenneroo

    glenneroo

    Joined:
    Oct 27, 2016
    Posts:
    229
    tl;dr: if you have a 2nd headset, try that

    Purely anecdotal and my solution might not be relevant or even correct but... I had this after getting v55 for a solid 2 weeks a few months ago. Drove me nearly to insanity. After changing every setting imaginable, commenting out code, tearing apart logs, factory resetting a lot (I really hate those demo videos + pairing controllers + phone), recreating my project from scratch with just the basics, etc. the only way forward for me was to use a different headset with a different user (my Meta game dev account).

    The only thing I can think of is some internal authentication was failing (and not being logged anywhere) with my personal Meta account which no longer had dev access (I was messing around with permissions for my AppLab submission around the same time and somehow broke something, which some nice person at Facebook fixed). Since there is a time limit how often you can change users on a headset, I wasn't able to switch to my dev account. Thankfully my backup headset was still in the original box i.e. had no Meta account assigned.. it then updated automatically to v55 but everything just worked as if nothing had happened.

    I haven't tried my other headset in awhile... but everything is working wonderfully right now, as they say, don't mess with a running system ;) Maybe someday I'll have the courage to try again.