Search Unity

  1. Read here for Unity's latest plans on OpenXR.
    Dismiss Notice

Help Wanted Mesh is distorted on Oculus Quest 2

Discussion in 'VR' started by danielesuppo, Sep 29, 2021.

  1. danielesuppo

    danielesuppo

    Joined:
    Oct 20, 2015
    Posts:
    231
    Hello,
    I've made a reconstruction of a room from photos with RealityCapture.
    I've imported this sigle mesh as .fbx, with all its materials (and textures).
    I'm using "Unlit/Texture" materials for the reconstructed model, just to see the textures.

    The Unity scene look perfectly in Unity Editor, and in a stand alone build.
    BUT, when I move to Oculus Quest 2, everything is a little distotrted (for example, a straight line texture become a waved line).
    I'm using ASTC 4x4 texture compression, so I think it should not be a matter of texture compression.
    For sure the 3d model is quite huge (1.3ML triangles), and have a lot of "sub materials" (so, sub meshes, each one with its own unwrap).
    Maybe is it a matter of geometry?

    Any help would be much appreciated!
     
    Last edited: Sep 29, 2021
  2. danielesuppo

    danielesuppo

    Joined:
    Oct 20, 2015
    Posts:
    231
    I'll try to explain better my issue, please see this screenshot from Editor (or PC build, is the same)


    Now please see this screenshot from Oculus Quest 2...

    As you will see all the textures are distorted....

    Here another comparison:


    This problem unfornutately is much visible with Oculus Quest...

    Any help?
     
  3. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    28,174
    Do you have mesh compression on high?

    To be honest without knowing what the wireframes are it is hard to tell. But it looks like texture compression to be. I don't know for sure as I'd need to see wires.
     
  4. danielesuppo

    danielesuppo

    Joined:
    Oct 20, 2015
    Posts:
    231
    Many thanks hippocoder for your reply.
    I don't have any mesh compression on my imported fbx, please see the settings:
    (P.S. I've also tried with "Oprimize mesh: Nothing", but does not change)


    This is the wireframe:


    I'm pretty sure that's a geometry issue, because another .fbx does not give me this kind of problem

    Many thanks!
     
    Last edited: Sep 30, 2021
unityunity