Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We’re making changes to the Unity Runtime Fee pricing policy that we announced on September 12th. Access our latest thread for more information!
    Dismiss Notice
  3. Dismiss Notice

Mesh deformed after import to Unity from Blender

Discussion in 'Animation' started by shuskry, Feb 21, 2022.

  1. shuskry


    Oct 10, 2015
    Hi everybody :)

    I'm trying to import from Blender my character with an Animation. But after imported, the model appear with some weird transformation .

    Here the screenshot:

    Like you can see , In unity, the model seems to be deformed with not the same level of smoothness.
    At the left under the arm, we can clearly see the bug.
    And in general , the model seems to be more "Low poly" ...

    Someone can explain me how to resolve that?

    I tried to find some information but nothing has work for now.
    In my export settings from Blender:
    I export My object with the armature as a .FBX file
    I disable "Add Leaf bones" and enable "Only deform bones".
    I have no modifier on my object.
    I also set the "Simplify" slider from "Bake Animation" menu to 0.00

    In the import Settings from Unity I set all "Keyframe Reduction" error to 0

    Thanks for helping me :D

    Have a good day !
    Last edited: Feb 21, 2022
  2. shuskry


    Oct 10, 2015
    Okay I found the solution !

    I need to go into Project Settings > Quality > other > Skin Weights.
    This parameter was set to 1 , If raise this number , I can see the deformation decrease until it disappears when I set to 4 :D
    halil_sekban likes this.
  3. Voxeldaddy


    Sep 25, 2018
    this comment saved my project... i had weighted and skinned my model multiple times thinking i was doing something wrong. You are a lifesaver.
    shuskry likes this.
  4. agelvik


    Nov 6, 2015
    thank you, i was so confused on what was wrong with my model / export settings!