Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We have updated the language to the Editor Terms based on feedback from our employees and community. Learn more.
    Dismiss Notice

Mesh-collider accuracy changes depending on scale

Discussion in 'Physics for ECS' started by btwist, Jan 29, 2020.

  1. btwist


    Jan 3, 2019
    So I am adding a PhysicsShapeAuthoring component to my meshes, and setting the type to mesh since I need 100% accurate collisions for a simulation. I then set the manually set the mesh variable (same mesh as is being rendered). The results are... incomplete. It's not turning the mesh 1:1 into the collider...

    Here you can see a wheel and a tyre:
    As you can see only a thin slice of the left mesh is incorporated into the collider, and rather random triangles are incorporporated on the right.

    If I scale the meshes up by a factor of about 5-10 the generated colliders are perfect... but is there a better way of fixing the problem?
  2. Adam-Mechtley


    Unity Technologies

    Feb 5, 2007
    Hi! If it is possible for you to submit a bug report containing the assets in question we could take a look