Search Unity

Mecanim animation are transfering inconsistently

Discussion in 'Animation' started by RosiePosie, Oct 29, 2013.

  1. RosiePosie

    RosiePosie

    Joined:
    Sep 19, 2013
    Posts:
    1
    Hello Everyone! I'm pretty new to Mecanim, so this might be something super easy to fix.

    I have a character using the Mecanim Humanoid system with Extra bones for the facial animations.

    When the time comes to play my animations, I get really weird results; The jaw bone (which is mapped in the avatar) either animates in reverse or parts of the skinned mesh seam to lose some of its influence to the jaw ( ex: the chin will go down, but the teeth will only move slightly even though they are skinned 100% to the jaw)

    If I go in my characters's Avatar and remove the jaw bone from the Mecanim mapping, one of my animations will actually start working : the jaw will move, even though there is no reason it should move at all! but only for that animation. all the others will disregard the jaw animation.

    I doubt it has anything to do with my animations because I can put my system in legacy and everything works like a charm. More so, I am currently working on two characters with the same system (Mecanim and facial rig) and that one works fine!



    Thank you for your help! :)
     
  2. TonyLi

    TonyLi

    Joined:
    Apr 10, 2012
    Posts:
    11,593
    You did the right thing by unmapping the jaw bone from Mecanim, since Mecanim and legacy shouldn't try to control the same bones. When I forget to unmap the jaw, I see the same issue on my models. Some animators create a rig with two jaw bones: one to assign to Mecanim, and another for legacy. It sounds like you're keeping extra bones when importing the rig, which is correct, because your legacy will need them for facial animation. Maybe some other face bones need to be unmapped from Mecanim, too.

    Could the problem character have a legacy animation set to Play Automatically?

    Another thing to try: when importing the body animation (not the character model), untick Keep Additional Bones.
     
unityunity