Search Unity

  1. All Pro and Enterprise subscribers: find helpful & inspiring creative, tech, and business know-how in the new Unity Success Hub. Sign in to stay up to date.
    Dismiss Notice
  2. Dismiss Notice

Max shadow requests count reached - How to get rid of this spam?

Discussion in 'High Definition Render Pipeline' started by skinwalker, Mar 5, 2021.

  1. skinwalker


    Apr 10, 2015
    I'm working on a level that has a couple of rooms and its becoming impossible to work on it because everytime I look at an area that has a lot of lights (even though they are not in the same room), this message is destroying my console and I get very low fps in the editor.

    Max shadow requests count reached, dropping all exceeding requests. You can increase this limit by changing the max requests in the HDRP asset
    UnityEngine.GUIUtility:processEvent(Int32, IntPtr)

    Keep in mind that Im using a very high end PC and this warning only appears in the editor. How can we turn it off as I think it makes 0 sense at least in my case?

    Setting the Maximum shadows on screen to 1000 fixes it but I'm not sure if it will have any performance consequences later on since I only get this lag in the editor I don't want to ruin my builds performance just so I cant get rid of a warning.