Search Unity

Help Wanted Material with Shader Graph is not shown if the camera is under object

Discussion in 'Shader Graph' started by arsnyan2002, May 3, 2019.

  1. arsnyan2002

    arsnyan2002

    Joined:
    Apr 30, 2019
    Posts:
    17
    Hi! I have a problem with materials. I use Blender's Sapling Tree Generator to make some trees. I imported them and they are looking good, if the camera is on the top. If it's not then I get this (Outline - the actual object, but mostly it's transparent, so that's the problem):

    This is my shader graph:

    I've tried to use double-sided parameter, but it didn't help (The transparent objects came white).
    As I understand, the problem is that the leaves are (is?) too thin in model.

    P.S. Yes, glossiness is important.
    P.S.S. I use LWRP, not HDRP
     
  2. bgolus

    bgolus

    Joined:
    Dec 7, 2012
    Posts:
    6,999
    Shader Graph doesn't handle two sided normals for you, so when you have Two Sided enabled the surface normals are still flipped. You need to flip the normals in the graph, both for the master node and for the fresnel effect node.

    upload_2019-5-8_9-56-20.png
     
  3. arsnyan2002

    arsnyan2002

    Joined:
    Apr 30, 2019
    Posts:
    17