Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

Question MARS Setup fails : Inaccessible due to protection level

Discussion in 'Unity MARS' started by RoryMercantile, Dec 9, 2022.

  1. RoryMercantile

    RoryMercantile

    Joined:
    Dec 18, 2021
    Posts:
    5
    Hi there --

    I'm having troubles getting MARS working with an existing AR project in 2020.3.20f1 on M1 Macbook Pro --

    I was able to go through the MARS tutorial in a new project when downloading the samples and tutorials, but when I tried adding it to an existing project, it started forcing me into Safe MODE with some 150 errors or so. I think part of that was that I hadn't signed up and started the trial subscription, but now I've got the subscription showing, and it's showing in my subscriptions, but opening up my existing project sends me into safe mode with various "Inaccessible due to protection level" in the Mars Pop up Field and the SimulationModeField, and if I exit safe mode, neither the MARS item or the Content Manager show up in the Window drop down.

    I've tried signing out of Unity Hub and signing back in, rebooting, etc., and it doesn't help.

    I've followed the guidance to install through the custom package, etc, but it doesn't seem to be tracking. I figure this is a newbie error but would love some help :)

    thanks!

    Rory