Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Bug "Machine identification is invalid for current license" Error

Discussion in 'Unity Hub' started by synok, May 17, 2020.

  1. synok

    synok

    Joined:
    Jun 7, 2011
    Posts:
    126
    Hello!

    I am a long-term trusted Unity user. I wanted to try out Unity again and still have a deja-vu feeling I posted about this, but cannot find my post at all. So here's the thing.

    I started Unity Hub to create a new project, but was welcomed with "Machine identification is invalid for current license. Double-checking I noticed that I don't have a license activated. So I tried "Activate new license" and went through activating a personal license. Now I got "Your license successfully activated" followed with the machine identification error. So after some digging people reported that I should pick manual activation, enter my MAC-address in the file, and activate it that way.

    Said and done, I can now see my license, so I download Unity and start a new project. Works without issues. However, when I close Unity and start it again, I am welcomed by the same error, and cannot seem to do the same workaround as before. This now prevents me in all ways from using Unity. So at this time, I tried;

    * The same activation procedure as done above.
    * Uninstalling VPN services and software.
    * Uninstalling / Reinstalling Unity & Unity hub.
    * Using different DNS.
    * Using different accounts.
    * Disabling antivirus.
    * Running as admin.
    * Performed the "Troubleshooting" steps, to no avail.
    * And finally, basically restarted my computer in between every first 5 steps above.

    Nothing seems to start Unity from this point. And I am just a casual user, following every basic step just to get it working. Many people seem to have had issues come and go with Unity Hub / licensing service.

    What else is there to try?

    EDIT (Potential fix): I found something that might have worked. This fix has been tested with multiple restarts of Unity Hub, restart of the computer, and still I can open the project fine (so far). It involves the manual activation method, but make sure that the letters in the MAC-address is lower-case. If they are upper-case (like the standard in ipconfig, also don't forget the colons instead of dashes), Unity will launch once, and not work upon reopening the project. Putting lower-case letters instead (for some strange reason) made it work for me. If I stumble upon more issues, I will repost here.
     
    Last edited: May 17, 2020
    masakatsu likes this.
  2. danielo_unity

    danielo_unity

    Unity Technologies

    Joined:
    Apr 12, 2018
    Posts:
    14
    Is it possible that you have a non-standard networking environment? Do you have an onboard network adapter?

    In case you haven't seen this yet, please check out this Troubleshooting Guide.

    If the selected adapter is empty, then you may (indeed) need to perform a manual activation, filling in the correct adapter address (should work whether the MAC address is upper or lower-case, but this may depend on the version of Editor, Hub and Licensing Client you are using).

    FYI: we fixed a bug in the selection of the MAC address, which will be landing in the upcoming version of Hub (2.3.2?)
    Hope this helps
     
    BasilUnity likes this.
unityunity