Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Luminosity and Gamma errors using URP with Windows XR plugin

Discussion in 'AR/VR (XR) Discussion' started by Mauro1965, Apr 30, 2020.

  1. Mauro1965

    Mauro1965

    Joined:
    Aug 31, 2019
    Posts:
    27
    I noticed a very strong contrast and gamma alteration after URP 7.1.8 and unity 2019.3.7f1 using XR windows plugin

    Starting from Unity 2019.3.12f1 If I use the Windows XR plugin i see crazy changes activating the postprocessing mode even without any postprocess overlay active. In some cases darker and on other super white like a strong fog.
    It's clearly visible a contrast difference between the camera window and the VR in the Mixed reality window (and so in the headset too).
    The problem is present in all versions i tried from the unity 2019.3.12f1 to the 2020.2.8a.
    Changing the plugin version or the URP version some artifacts change (from darker to foggy).
    Usually if the post processing is disabled only a darker view is present but with the postprocess active every version gives its own different style and artifacts.

    If i use the unity Mock XR HMD pluging i don't see the problem and if i disable the XR reactivating the OpenVR deprecated mode the issue disapper.
    So i'm quite sure the Windows XR plugin has a bug

    I tried all available versions and combinations with the URP up to the URP 9.0..0 and XR Windows 3.1.6

    The issue is visible with any project even an empty scene with a plane or better with the default URP template scene. With some versions the FXAA antialiasing creates a white fog, instead being a normal smoothing filter.

    I hope to do something wrong but i spent one entire day testing all versions with the URP default template and i'm quite sure about the issue.

    Do you have noticed this issue?

    After other tests i discovered that this issue appears in the 2019.3.12f1 with the same URP & XR versions that in the 2019.3.7f1 doesn't cause any problem. So it's something more related the unity version than a XR or URP package version.

    In brief:
    The last combination ok is URP 7.1.8 in Unity 2019.3.7f1 (any XR version) the problem then appears in Unity 2019.3.12f1 URP 7.3.1 and it is still present on the last beta and alfa version 2020.1.7b and 2020.2.8a in all URP and XR package version combinations
     
    Last edited: May 1, 2020