Search Unity

Lost HD hub was installed on, can't uninstall or reinstall on another drive

Discussion in 'Unity Hub' started by lmbarns, Jun 10, 2021.

  1. lmbarns

    lmbarns

    Joined:
    Jul 14, 2011
    Posts:
    1,537
    Lost the hard drive Hub was installed on. Now it shows up in "Add or Remove Programs" but when I try to uninstall it says the "System cannot find the drive".

    I downloaded the hub installer, when I run it, it just says "Installation Aborted" Setup was not completed successfully.

    I went through Appdata, Program Data, etc and deleted any references to hub but still can't install...what else can I do?

    edit:: Looking through another thread, deleting the registry value with CCcleaner fixed it, don't see a way to delete this post so just updating with the fix.

    edit 2:: I had to install an old version of hub, but when I click the upgrade button in hub it fails just like before so I'm stuck with the old 1.6 version.
     
    Last edited: Jun 10, 2021
  2. UnityJuju

    UnityJuju

    Unity Technologies

    Joined:
    Jun 15, 2021
    Posts:
    149
    Hi there! Are you still having trouble with it?
    We recommend you to go to Unity.com and download the latest version of the Hub.
    Let us know if it works!
     
unityunity