Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Lit Shader, can "Receive shadows" be disabled on emissive materials?

Discussion in 'High Definition Render Pipeline' started by Dreamback, Aug 14, 2019.

  1. Dreamback

    Dreamback

    Joined:
    Jul 29, 2016
    Posts:
    220
    We have cars in our scene, and their brake lights are receiving shadows when lit up, which makes no sense. They aren't actual scene lights, they are using an emissive material with the Lit Shader. Is there a flag to set for them to not receive shadows?
     
  2. iSinner

    iSinner

    Joined:
    Dec 5, 2013
    Posts:
    201
    Yes, in the mesh renderer.
     
  3. Dreamback

    Dreamback

    Joined:
    Jul 29, 2016
    Posts:
    220
    There is no such option. It has cast shadows, but not receive.

     
  4. iSinner

    iSinner

    Joined:
    Dec 5, 2013
    Posts:
    201
    Oh, you are using deferred rendering, that info box is for a reason there, because instead of it there should be a receive shadow flag, not in deferred rendering though.

    Are you sing a built in shader?
    What unity version, rendering pipeline, shader name?

    If it is the standard shader, i wouuld recommend making the color of emission not leave out any color channel, for example if you put the color R and G to 1, then the shadow will remain a bit yellow

    but if you bump the B channel a bit, then it will vanish while the emission remaining still yellow-ish


    In general, it is weird. Before the PBR(unity 4-), the emission channel would dictate what color the thing should be regardless of the lighting conditions, now there is a shadow on an emissive surface.
    Does this even happen in real life conditions?