Search Unity

  1. We are migrating the Unity Forums to Unity Discussions by the end of July. Read our announcement for more information and let us know if you have any questions.
    Dismiss Notice
  2. Dismiss Notice

Question List of 2019.1 dependencies for Linux?

Discussion in 'Linux' started by polygonalcube, Apr 23, 2023.

  1. polygonalcube

    polygonalcube

    Joined:
    Dec 19, 2017
    Posts:
    1
    I am on a laptop with Pop!_OS 22.04 (Ubuntu 22.04 derivative) and I need to open a project made with 2019.1. I have the Unity Hub flatpak installed, and Unity 2021 projects open just fine. Unity 2019 projects don't open at all. Even tested with the latest 2019.4 LTS. My current theory as to why this is the case is that there are deprecated/missing dependencies needed to run Unity. The only problem with testing this theory is that there seems to be no info on what Unity 2019 Linux dependencies actually are. Does anyone know?
     
  2. sfjohansson

    sfjohansson

    Joined:
    Mar 12, 2013
    Posts:
    371
    At least for supported distros, it was Ubuntu 18.04...it's quite possible that Unity 2019 doesn't even work on Ubuntu 2020...let alone 2022.

    What the dependencies might be...I have no clue apart from the current libSSL issue that has stopped me from trying to upgrade to 22.04 https://forum.unity.com/threads/running-unity-on-ubuntu-22-04.1284083/
     
  3. Flavelius

    Flavelius

    Joined:
    Jul 8, 2012
    Posts:
    945
    if you run the unity editor directly (not the hub) from the command line you'll get helpful output that complains what dependencies are missing. This way i was able to get 2019.3 to work in my case (on 23.04), even though it failed with empty console errors - for missing icu libraries when trying to compile scripts which i wasn't able to fix.
     
  4. unity_AHANAFRASHID

    unity_AHANAFRASHID

    Joined:
    Jan 16, 2021
    Posts:
    7
    Well there might be a dependency error out there. I have xubuntu and can not use unity 2019 or older. Because unity older that 2019 version can not run on dconf. they need the registry manager gconf. So it is possible that there might be a dependency error which is even preventing unity engine from starting. Try to know where is the error.