Search Unity

  1. Unity Asset Manager is now available in public beta. Try it out now and join the conversation here in the forums.
    Dismiss Notice

Linux: Scene view + project drag stopped working, asset import external process filled 64gb of ram

Discussion in '2021.2 Beta' started by MostHated, Jun 12, 2021.

  1. MostHated


    Nov 29, 2015
    I just wanted to make it known that the first time I tried to open my project in 2021.2.0a19 I started looking around at some of the new features when suddenly scene view dragging stopped working properly. If I held the right mouse button to move the camera, for maybe 1-2 frames after the initial click and hold while moving the mouse, the camera would move a tiny bit but then stop. I would let go of the mouse button and try again to drag, but 9 out of 10 times it would not do anything, but that 1 of 10 times it would move again for 1 or so frames.

    It seemed and felt like I was having an extreme amount of frame latency (like 1 frame per 10 seconds) but it wasn't, as if I were to hold the right mouse and use WASD, I could move around the scene just fine, I simply could not drag the mouse.

    I closed the project and reopened and it started to work again so I moved on to looking at other things, and at some point I went to rearrange a folder and went to drag it in the project view to another folder and when I let go, nothing happened. I went to try again and nothing. Randomly a few minutes later, as if dragging the folder a few times was queued up, it tried to actually do it multiple times in a row and errored out. It was then that I noticed that moving the camera in the scene view no longer worked again, so it seemed like the issue wasn't exactly scene view or camera movement related, but with editor dragging in general that was having an issue.

    That aside, I also went to try out the Asset Import using external process, and after enabling it, I glanced at my Conky system monitor and quickly realized that my ram was filling up fast. I went to look at the system processes and saw this:

    I was able to kill processes just in time before my system locked up. I have not opened 2021.2 since.


    ---- Edit: I opened it back up to play around some more and went to drag an editor window tab and got a crash related to dragging. At the time this occurred, I was unable to drag the camera again, but there were no messages or anything in the logs relating to what might be going on. I was in process of trying to open and run the profiler in editor mode to see if I could see anything, but trying to drag that window triggered the crash this time.

    Code (CSharp):
    1. Obtained 22 stack frames.
    2. #0  0x0055b1c73cde9c in burst_signal_handler(int, siginfo_t*, void*)
    3. #1  0x007f5a60befbb0 in funlockfile
    4. #2  0x0055b1c891b890 in ContainerWindow::ToggleMaximize()
    5. #3  0x0055b1c8911898 in GUIView::UpdateScreenManager()
    6. #4  0x0055b1c8915e70 in OnGUIViewButtonRelease(GUIView*, void*)
    7. #5  0x007f5a619646fb in gtk_window_position_get_type
    8. #6  0x007f5a612018fa in g_closure_invoke
    9. #7  0x007f5a612144b3 in g_signal_handler_disconnect
    10. #8  0x007f5a6121a5a6 in g_signal_emit_valist
    11. #9  0x007f5a6121adc3 in g_signal_emit
    12. #10 0x007f5a6190d514 in gtk_requisition_copy
    13. #11 0x007f5a617bbd50 in gtk_lock_button_set_permission
    14. #12 0x007f5a617bda93 in gtk_main_do_event
    15. #13 0x007f5a61495e89 in gdk_drawing_context_is_valid
    16. #14 0x007f5a614ca8e6 in gdk_x11_drag_context_get_type
    17. #15 0x007f5a6110e62b in g_main_context_dispatch
    18. #16 0x007f5a6110e8d8 in g_main_context_dispatch
    19. #17 0x007f5a6110ebf3 in g_main_loop_run
    20. #18 0x007f5a617bc9fd in gtk_main
    21. #19 0x0055b1c8928f0c in main
    22. #20 0x007f5a60a19cb2 in __libc_start_main
    23. #21 0x0055b1c6bae029 in _start
    Last edited: Jun 12, 2021