Search Unity

Linux Bug in UnityHub 0.20.1: Failed to install Mac/Windows Build Support (Mono)

Discussion in 'Unity Hub' started by mosaic_school, Aug 31, 2018.

  1. mosaic_school

    mosaic_school

    Joined:
    Dec 12, 2012
    Posts:
    63
    Amazing to see the first version of the UnityHub being available on Linux. Truly exiting!

    I guess this is a known issue but just in case:

    When installing the latest 2018.2.6f1 or the LTS 2017.4.10f1 version, both fail to install the Windows/Mac build support (and the Standard Assets and Example project for the later) . The WebGL component installs just fine.
    The same error comes when trying to install them later them via `Add Compoment` which yields the same error.



    I run Ubuntu 18.04 and set the default location to /home/user/Apps/Unity/ but don't see any logs even when launching the AppImage from the terminal.
     
  2. Tbond

    Tbond

    Joined:
    Oct 7, 2017
    Posts:
    2
    The same problem here, with the Android module.
    Debian Buster, Unity 2018.2.6f1 (only tested module post installation)
     
  3. hunabku94

    hunabku94

    Joined:
    Jun 12, 2017
    Posts:
    11
    Same in Arch Linux for Unity 2018.2.6f1.
    Same for me, no logs.
     
  4. BitPurity

    BitPurity

    Joined:
    Aug 27, 2017
    Posts:
    1
    I'm running into the same issue on Windows 10. After a fresh install of Unity Hub, I try to install Unity 2018.2.7f1 with Mac build support. I get "Editor Download Failed: Incomplete or corrupted download file"

    I found that downloading Unity with no components, then adding the component afterwards works.
     
  5. hunabku94

    hunabku94

    Joined:
    Jun 12, 2017
    Posts:
    11
    Install Unity only and install component after don't fix it on linux but thanks for your proposal BitPurity
     
  6. lucasxav

    lucasxav

    Joined:
    Feb 14, 2015
    Posts:
    3
    Same for me, using Linux Mint 19, trying to install 2018.2.9f1
     
    Last edited: Sep 23, 2018
  7. mosaic_school

    mosaic_school

    Joined:
    Dec 12, 2012
    Posts:
    63
    What is super strange is that I have two notebooks running Ubuntu 18.04 and both had the problem initially. However, on one now all the components install just fine but the on the other the same error persists. I just tried it with the latest
    Unity-2018.2.10f1
    . Also both are running Unity-Hub-1.0 now (on the one where it works it automatically upgraded and I have a fresh install of 1.0 on the one where it doesn't but I don't think that's relevant).

    @Charles_Beauchemin any idea I'm missing a particular ubuntu package on the computer it doesn't work?
     
  8. Mattallurgy

    Mattallurgy

    Joined:
    Apr 24, 2017
    Posts:
    1
    Was this ever solved? I just installed 2018.3.1f1 via Hub 1.4.0 on Ubuntu Budgie 18.04.1, and I'm getting the "Failed to install Mac/Windows Build Support (Mono)" message. Do I need to have something else installed? I have Rider installed as my C#/.NET IDE, so I'm not sure if that is the issue.
     
  9. mosaic_school

    mosaic_school

    Joined:
    Dec 12, 2012
    Posts:
    63