Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Lightning is super dark when Editing Prefab Asset

Discussion in 'Editor Workflows' started by Justice0Juic3, Jan 20, 2019.

  1. Justice0Juic3

    Justice0Juic3

    Joined:
    Apr 29, 2013
    Posts:
    188
    As the title suggests I'm having an issue with editing prefabs.
    Whenever I Open the Prefab Asset the scene becomes very dark. In some way logical because there's no Directional Light in the scene but it'd be helpful if there was an independent one.
    Here's a pic:


    I hope this will be solved, thanks.

    Edit: I'm not entirely sure if this topic belongs here but thanks in advance.
     
  2. Grimreaper358

    Grimreaper358

    Joined:
    Apr 8, 2013
    Posts:
    789
    Seems like your default prefab editing scene is bugged. You can make one for yourself and assign it. Edit -> Project Settings -> Editor

    upload_2019-1-20_13-56-4.png
     
    gesicht likes this.
  3. Justice0Juic3

    Justice0Juic3

    Joined:
    Apr 29, 2013
    Posts:
    188
    Thanks, didn't know you could change this setting. Sort of fixed it but can still see a super black shadow, hope this get fixed soon. Even a simple sphere prefab looks a bit dark.
     
  4. Baste

    Baste

    Joined:
    Jan 24, 2013
    Posts:
    5,955
    You should make a post about it in the prefabs forums, as the people making the prefab systems read that more often.
     
  5. Klodivio355

    Klodivio355

    Joined:
    Jul 9, 2019
    Posts:
    1
    I know It is really old, but I fixed it by going Window -> Rendering -> Lighting Settings -> Generate Lighting. It fixes the issue perfectly.
     
    Grafikacy likes this.
unityunity