Search Unity

lightmaps look really bad

Discussion in 'Unity 5 Pre-order Beta' started by kryptopath2, Dec 15, 2014.

  1. kryptopath2

    kryptopath2

    Joined:
    Jul 19, 2013
    Posts:
    104
    i have scene i wanted to lightmap. shaders are all standard, lightmap-resolution is 100 texels.
    with realtime-lighting:



    with lightmap:


    aside from the blocky texture, the colors are strange. and the lightmap in the small tree gets white.
    on a sidenote, i cannot select the lightmaps in the lightmap-tab. they are listed there and i see the scrollbar, but i can not use it as it is frozen...
    i tested this in beta 13, 14 and 17.
     
  2. AustinRichards

    AustinRichards

    Joined:
    Apr 4, 2013
    Posts:
    321
    Submit a bug report and attach the case # to this post. Also try messing around with the lightmap settings.
     
  3. kryptopath2

    kryptopath2

    Joined:
    Jul 19, 2013
    Posts:
    104
    submitted a bug, but didn't get a number..
    messing with the settings didn't change anything, it looked even worse :(
     
  4. KEngelstoft

    KEngelstoft

    Unity Technologies

    Joined:
    Aug 13, 2013
    Posts:
    1,320
    Did you receive a bug number by now?

    Have you tried disabling compression on the light maps, to rule that out as source of the artifacts?
     
  5. kryptopath2

    kryptopath2

    Joined:
    Jul 19, 2013
    Posts:
    104
    hi,
    no, i didn't get a number yet.. compression didn't change anything. i used a higher number of resolution (100) and atlas size (2048) but it still looks very fragmented. the white artifacts on the transparent objetcs are still there (also between the windows on the left).
     
  6. KEngelstoft

    KEngelstoft

    Unity Technologies

    Joined:
    Aug 13, 2013
    Posts:
    1,320
    @kryptopath2 Any chance you could share your scene? I would like to take a look at those artefacts...
     
  7. kryptopath2

    kryptopath2

    Joined:
    Jul 19, 2013
    Posts:
    104
    i will send you a download-link with the scene.
     
  8. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    27,995
    If you haven't got a bug number you should probably check your spam folder.
     
  9. KRGraphics

    KRGraphics

    Joined:
    Jan 5, 2010
    Posts:
    4,016
    I would go for a higher texel count... for realtime bakes, 2-6 should be sufficient. For baked lightmaps, try 512 which should get rid of your artifacts. 100 is too low.
     
  10. Meltdown

    Meltdown

    Joined:
    Oct 13, 2010
    Posts:
    5,668
    Did you submit your bug through the editor or email bugs@unity directly?

    I've had some cases where sending an email to bugs@unity didn't get me a case number.
    Should I submit a bug for that bug in the bug reporter? :rolleyes:
     
  11. kryptopath2

    kryptopath2

    Joined:
    Jul 19, 2013
    Posts:
    104
    through the editor. i submitted a few bugs in the last weeks and always got a number. i will try to ramp up the resolution and see if this is better. thanks for the support!!

    edit: tried the suggestions. a bit better, but the white places became worse. is submitted a bug and got a number :)
    660565
     
    Last edited: Jan 3, 2015
  12. KEngelstoft

    KEngelstoft

    Unity Technologies

    Joined:
    Aug 13, 2013
    Posts:
    1,320
    Thanks, got it! From a quick look, you should increase Realtime Resolution. And 512 baked resolution is way too high, try 50 :) I'll take a more in-depth look tomorrow.
     
    KRGraphics likes this.
  13. kryptopath2

    kryptopath2

    Joined:
    Jul 19, 2013
    Posts:
    104
    512 was worth a shot ;)
    thanks for your help!!
     
  14. KRGraphics

    KRGraphics

    Joined:
    Jan 5, 2010
    Posts:
    4,016
    512 is too high, but during testing, it worked out well... I have my Cornell Box set to 1024 and I just carefully keep emission objects from the light map atlas. No sense in keeping luminous polygons in the lightmap atlas
     
  15. KEngelstoft

    KEngelstoft

    Unity Technologies

    Joined:
    Aug 13, 2013
    Posts:
    1,320
    Hi! The artifacts were due to compression. Here are some screenshots for comparison (baked resolution of 40):

    compressed.png uncompressed.png
     
    KRGraphics likes this.
  16. KRGraphics

    KRGraphics

    Joined:
    Jan 5, 2010
    Posts:
    4,016
    That is beautiful... :) And I have been using lower settings on my Cornell Box scene and it looks just as good.
     
  17. kryptopath2

    kryptopath2

    Joined:
    Jul 19, 2013
    Posts:
    104
    thanks a lot! strange, i unchecked compression at one test, but it seems i didn't do it properly. much happier now :)
     
unityunity