Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Lightmapping too slow (tested of several system)

Discussion in 'Global Illumination' started by idurvesh, Jul 24, 2015.

  1. idurvesh

    idurvesh

    Joined:
    Jun 9, 2014
    Posts:
    495
    Hello ,We are developing racing game, our race track size is big as in case of any race game.

    We are light mapping the scene, the lightmapp settings area as follows,
    Precomputed Realtime GI disable.
    Baked GI Baked resolution is 10
    and other default settings.

    The thing is the lightmapping process takes lot of time to complete its.

    Its been 28 hours and still haven't passed 7 / 11 with 655 Jobs.

    We have tried it on different System the time it is taking is almost same time without completing its process

    First PC Config is,
    2.5 GB of video memory/Graphic card
    4 GB of Ram
    Win 7 32 bits.

    Second PC Config,
    2 GB of video memory
    8 GB of Ram
    Win 7 64 bit

    Macbook Pro,
    1 GB of video memory,
    6 GB of RAM
    Yosemite

    So my question is,is it usual for Lightning to take this much amount of time?
     
  2. essimoon2

    essimoon2

    Joined:
    Nov 13, 2013
    Posts:
    195
    Wow your scene must be huge :O
    We're baking with 50 regularly and getting at least results in most cases after one night of baking. 655 Jobs seems to be an extraordinary amount as well. I never got more than two digit numbers of jobs.

    But yeah, it takes long in my case as well. Got 8 GB of Ram which currently seems to be my bottleneck. Any chance you can try on a pc with more ram?
     
    idurvesh likes this.
  3. idurvesh

    idurvesh

    Joined:
    Jun 9, 2014
    Posts:
    495
    aha yes the scene is very huge, it started from 1037 Jobs and by the time it reaches to 655 it killed system.

    Will increase in RAM help? As I see people with 32 GB RAM also having similar problem

    We are considering not to use Precomputed and Baked GI at all which may very well reduce overall look and feel of game with no shadows.
     
  4. KEngelstoft

    KEngelstoft

    Unity Technologies

    Joined:
    Aug 13, 2013
    Posts:
    1,366
    You should consider decreasing the realtime/indirect resolution.

    Also, have a look at the charting scene view mode and check that you are using a resolution that makes sense for your scene.

    You should also check the Auto UV settings for your objects, the chart stitching is will perform much better and speed up the bake if you set good values.
     
    idurvesh likes this.
  5. idurvesh

    idurvesh

    Joined:
    Jun 9, 2014
    Posts:
    495
    @KEngelstoft low resolution to 4 and including all objects to empty game object and setting that parent object's scale to 0.1 in all axis do help in solve baking problem.Though in that low resolution everything gets too darky.Increasing bake resolution from 4 will always give me different kind of errors per bake.

    My models are not Auto UV ,so will try by checking that option on.

    What is "charting scene view mode" ? Are you refring to "UV Charts" option? How to decide on resolution looking at it?