Search Unity

LightMapping Problem !

Discussion in 'Editor & General Support' started by MR.Dawoodi, May 6, 2011.

  1. MR.Dawoodi

    MR.Dawoodi

    Joined:
    Dec 11, 2010
    Posts:
    22
    hi,
    i build a scene with 1direclight.
    but i can't take a light map with unity!
    you can see lightmap setting at here,
    light map build with high speed but light map don't have shadow!
    all object's are "Static" :confused:
    at my scene 1object with animation and this object not static,i delete it but lightmapp not compelet !
    PLZ help me :confused::confused:

    +sry About My English:rolleyes:
     
    Last edited: May 7, 2011
  2. br0kenp0ly

    br0kenp0ly

    Joined:
    Jun 3, 2008
    Posts:
    481
    Hi there!

    Do you get any error messages in the console?
    Did you generate lightmap uv`s in the import settings?


    Roald
     
  3. MR.Dawoodi

    MR.Dawoodi

    Joined:
    Dec 11, 2010
    Posts:
    22
    No error , no warning !
    yes i generate lightmap uv's after import objects !
     
  4. br0kenp0ly

    br0kenp0ly

    Joined:
    Jun 3, 2008
    Posts:
    481
    Hmm...

    Did you make sure the "Use Lightmaps" checkbox is on?



    Does your lightsource cast shadows? Not that it really matters, as you would have a visible lightmap from the GI anyways.

    If you still can`t get it to work, feel free to send me the scene so I could have a closer look :)

    Roald
     
  5. MR.Dawoodi

    MR.Dawoodi

    Joined:
    Dec 11, 2010
    Posts:
    22
    my project is over 330MB !
    how can i send it for you !?
     
  6. br0kenp0ly

    br0kenp0ly

    Joined:
    Jun 3, 2008
    Posts:
    481
    That`s quite large, right, but get yourself a Dropbox account put it there if you can :)

    www.dropbox.com
     
  7. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    25,648
    You can probably stop using exclamation marks now because it makes you remind me of someone very near a nervous breakdown.

    All your lights need to be set to cast shadows. If you untick hard and soft shadows on the actual lights, beast wont use them to lightmap. Are you testing this with a simple diffuse shader too?