Search Unity

Lighting Issues with the Lightweight Render Pipeline

Discussion in 'Package Manager' started by martythezebra, Apr 23, 2019.

  1. martythezebra

    martythezebra

    Joined:
    Feb 25, 2018
    Posts:
    3
    I just updated to Unity 2019.1.0f2 and decided to update a project I've been working on for a while now to use the Lightweight Render Pipeline so I could get some cool effects out of the Shader Graph. I watched this Brackey's video (
    ) to set it up. The problem is, after setting up the LRP and converting all of my materials in the project to work with the LRP, it seems none of my lights work. The room is just dark. Granted, I have a lot of lights in my scene, and when you disable the majority of them, some of them seem to work, but this just doesn't make sense to me. I have my light settings set to 'Per Pixel' and the max, 4 lights per object. No matter what combination of setting I use, the light just don't seem to all want to be on at once. I've removed and reinstalled different versions of the LRP , including the verified one, but I get the same results. At this point, I'm also willing just to go back to the standard built-in Unity Rendering system if anyone know how to revert all of my materials without manually going through all of them. There are upward of 500 materials in my project so far and I can't find a button to get them back to their original state like I was able to when switching to the LRP. I'm sort of stuck, so if anyone is able to help me in any way, I'd greatly appreciate it.
     
  2. BorisMongeau

    BorisMongeau

    Unity Technologies

    Joined:
    Feb 24, 2017
    Posts:
    57