Search Unity

Lighting is not working as intended

Discussion in 'Global Illumination' started by Rosie-Posie, Apr 22, 2016.

  1. Rosie-Posie

    Rosie-Posie

    Joined:
    Nov 20, 2013
    Posts:
    54
    Hello everyone,

    So I decided to get acquainted with the new lighting system. At first I though I was bad at it, but now I just think unity 5.3.2 and 5.3.4 is bugging out on me. So first issue I noticed is that if I have a simple cube (standard shader) in a new scene and activate and deactivate the directional light, the sky-box wont change colour like it usually does and the cube will only be slightly effected. If I then activate or deactivate a light that has a very intense colour, it will not effect the model at all.

    Steps to reproduce:
    1. Create a new 3D project.
    2. open a scene and create a cube and a point light.
    3. Check and see if the lights are effecting the cube.

    Attached you will find a gif of the issue.

    I've also just noticed that this is not limited to the standard shader. I am trying other lit shaders and have the same issue. Lighting seems to be completely broken in all of my Unity 5 installations. It is also not project related either, I have the same issue in projects that are opening fine on my other pc in both Unity 5.3.2 and 5.3.4.

    So am I going crazy, did I forget something obvious or is this a bug?
     
    Last edited: Apr 22, 2016
  2. Rosie-Posie

    Rosie-Posie

    Joined:
    Nov 20, 2013
    Posts:
    54
    ok so.... guess the answer was in my face all along, I had toggle off the lights in my scene!
     
    Last edited: Apr 22, 2016
unityunity