Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Bug Licensing Error

Discussion in 'Editor & General Support' started by gelfandnat, Jul 26, 2022.

  1. gelfandnat

    gelfandnat

    Joined:
    Aug 24, 2021
    Posts:
    1
    A few days ago, when I tried to open a project through the hub, it loaded for around a minute but didn't open the editor. I checked the editor log and came across this message:

    LICENSE SYSTEM [2022725 20:37:41] Next license update check is after 2022-07-27T00:37:42

    LICENSE SYSTEM [2022725 20:37:41] Machine binding 4 mismatch: (value of current machine) [String of text]= != [Other String of Text] == (value in license file). Reason might be there is a hardware change on this machine after the license was activated. Machine identification is invalid for current license.

    LICENSE SYSTEM [2022725 20:37:41] Current license is invalid and cannot be activated. You must delete the license file and then activate a new license on current machine.
    Exiting without the bug reporter. Application will terminate with return code 0

    When I opened a new project, it told me to check the logs. They mention there is a "Binding4 mismatch" and
    that it "Cannot find binding5 (MAC Address)." I located these bindings in the license file, but I'm not sure what they mean or what to do to them. From what I've researched, they seem to be related to my Wi-Fi/Ethernet connection.

    I have tried:
    - Reinstalling my license
    - Manually activating my license, both with and without the command prompt method
    - Reinstalling Unity and the Unity Hub
    - Going to an older version of the Unity Hub
    - Changing the text of bindings 4 and 5 from the license file to match my Wi-Fi (after which Unity told me the license I tried to submit was invalid)
    - Creating a new account
    - Disabling and re-enabling my Wi-Fi
    - Restarting my computer several times

    All of these methods have failed. I am relatively new to Unity, so I haven't experienced an issue of this magnitude before. Solutions from many other forums have not worked, so I decided to create a post of my own in hopes of responses specific to my situation. Thanks.
     
  2. tonywf15

    tonywf15

    Joined:
    Oct 11, 2022
    Posts:
    1
    Have you solved it yet? I'm having literally this exact problem right now and I've found no solutions so far.
     
  3. jongning

    jongning

    Joined:
    Jun 14, 2022
    Posts:
    1
    Same here try to reach support.
    My Unity Hub keeps denying my Unity license. So, I can't access any game folder. I have my Unity Licence as a Student Plan but can't use Unity. I've been trying to fix it by uninstalling it, another method that I have tried is manually installing but it fails to download on Step 3. I don't know why...