Search Unity

Lenovo Mirage prevent timeout settings

Discussion in 'Daydream' started by Mikeywardle13, Sep 12, 2019.

  1. Mikeywardle13

    Mikeywardle13

    Joined:
    Jan 13, 2019
    Posts:
    3
    I'm trying to create an application the runs on a Lenovo Mirage VR Solo that runs Daydream.

    The Application doesn't use the controller and if the controller is not moved for a period of time I get a prompt saying "Are you still there?" and if I don't move the headset it goes into standby mode.

    I can't seem to find a way to disable these in the headset settings, is there a way to configure this in Unity? (Or if anyone does know how to change the system settings that would also be useful).
     
    ROBYER1 likes this.
  2. ryokuro_psychic

    ryokuro_psychic

    Joined:
    Jun 13, 2019
    Posts:
    1
    We had the same problem ! It's annoying :(
     
  3. from2001vr

    from2001vr

    Joined:
    Dec 23, 2018
    Posts:
    1
    We are also facing the same problem!!
     
  4. Mikeywardle13

    Mikeywardle13

    Joined:
    Jan 13, 2019
    Posts:
    3
    So I think this issue occurs due to a recent Daydream update (sadly I can't find anyway to revert to a previous OS version). That being said I finally solved the issue (sort of):

    1. Go to developer settings and turn On "Stay Awake"
    2. Go to Apps & Notifications ->Advanced-> Special app access-> Battery Optimisation then find the app you want to run in "All apps" and select "don't optimise"
    3. Make sure your controller is ALWAYS being charged.

    This works for my project since we have max 6 users at a time but not sure how practical this is for other use cases

    Also quick side rant about my experience here:

    There is NO SETTING TO CHANGE THIS (even changing the properties via adb command line doesn't seem to work). Also I called up both Lenovo and Google support. Lenovo support said they didn't really support the Mirage but ended up telling me that it wasn't something your supposed to be able to change.

    Google support just sent me straight back to Lenovo support :mad:

    If anyone working for Daydream VR see's this :
    a) please add a setting to prevent sleep mode (I understand trying to save battery but some of us don't want that)
    b) please train your support teams to support Daydream VR devices (You made the software, you should support it)​

    @from2001vr @ryokuro_psychic hopefully something here helps you. Let me know if you find another solution
     
  5. unity_sEV_B7ZmIxj0Ug

    unity_sEV_B7ZmIxj0Ug

    Joined:
    Sep 4, 2018
    Posts:
    1
    Hi, I tried your solution but not worked for me. It may have an effect to delay the alert 5 min or so (not strictly confirmed), but the alert showed up again anyway.

    Basically the alert pops up after 10 min of non clicking. So my current workaround will be clicking tap area of controllers every 8 to 9 min. Very cumbersome though.
     
  6. Mikeywardle13

    Mikeywardle13

    Joined:
    Jan 13, 2019
    Posts:
    3
    Are you sure... After doing this I've been able to have the headset on for hours without pressing a button

    Did you restart the headset after changing the settings? maybe that helps?
     
  7. danmunslow74

    danmunslow74

    Joined:
    Sep 17, 2019
    Posts:
    1
    I am trying to work a solution. Our film is over 10mins. So the solutions above dont help.

    Has anyone a solution on a roll back of the operating system?

    I have headsets on the old operating system that does not have this issue.
     
  8. wrecche

    wrecche

    Joined:
    Oct 16, 2019
    Posts:
    1
    I've tried everything in this tread and still I am asked "Are you still there?" which is a pointless thing when doing anything with this useless device.

    lenovo won't help... we need someone to mod this firmware. simple as that.
     
  9. usb420

    usb420

    Joined:
    May 4, 2013
    Posts:
    2
    Anyone get this working? It's the most annoying thing ever.
     
unityunity