Search Unity

  1. Read here for Unity's latest plans on OpenXR.
    Dismiss Notice

Help Wanted Layer 3 is a reserved layer - Did I break something?

Discussion in 'Unity MARS' started by dweeh, Dec 8, 2020.

  1. dweeh

    dweeh

    Joined:
    Mar 20, 2018
    Posts:
    45
    When I run the Factory Training template - and the UI gets activated by the image marker - all the UI gets visible at once.

    When I start up a new project and import Mars - I get the warning:
    An AssetDatabase Refresh is pending after a successful Package Manager request. You should not call AssetDatabase.Refresh at this time because it can lead to import-related errors.

    and also:
    Layer 3 is a reserved layer and should be changed. Some functionality may not be available or you may have collisions with other systems.
    UnityEngine.Debug:LogWarningFormat(String, Object[])
    Unity.MARS.Simulation.SimulationEnvironmentSettings:OnValidate() (at Library/PackageCache/com.unity.mars@1.2.0/Runtime/Scripts/Simulation/SimulationEnvironmentSettings.cs:52)

    I tried
    starting new projects,
    reinstalling the Unity version
    and deleted the Mars installer and downloaded a new version.


    I did mess around with some of the shaders earlier - can I have broken something that bad? :(
    Also changed the
    <Your-Project>/Library/PackageCache.com.unity.mars@<version>/Runtime/Shaders/DepthMask.shader
    <Your-Project>/Library/PackageCache.com.unity.mars@<version>/Runtime/Shaders/TexturedFresnel/TexturedStableFresnel.shader
    since I wanted to use the Universal Render Pipeline

    What to do? :(
     
  2. dweeh

    dweeh

    Joined:
    Mar 20, 2018
    Posts:
    45
    Now I uninstalled all versions of Unity + the Hub.
    I deleted the Unity Folders Under Appdata before reinstalling.
    Started a new project - but I still get the same problem when I import Mars and try to run the Factory Training template.


    Is it just the occlusion shader that is F***ed up? Would that cause the warning about Layer 3?
     
  3. Jono_Unity

    Jono_Unity

    Unity Technologies

    Joined:
    Apr 5, 2016
    Posts:
    14
    Hi dweeh! Sounds like a few things going on here, and sorry you've gone through so much trouble about that Layer 3 issue! That layer is re-assignable in Project Settings -> MARS -> Simulation -> Environment Settings:
    upload_2020-12-9_12-0-0.png
    Set that to any open layer and you'll be be free of those warnings. Thanks for flagging that warning, we'll get that resolved for the next release.

    About the Factory Training template and all UI becoming visible at once: I see that you're using MARS 1.2, where we improved image marker discovery, which is what sounds like is going on here (previously, all image markers were discovered immediately rather than when you look at them). Can you check for me: search your project for "SimulatedDiscoveryIsland", with the "All" filter. You should see what I have here: a row for "IProvidesMarkerTracking" : "SimulatedDiscoveryMarkerProvider". If that instead says "SimulatedMarkerProvider" (no 'Discovery'), or any other entry, we'll be able to debug from there.
    upload_2020-12-9_12-5-14.png

    Thanks dweeh!
     
  4. dweeh

    dweeh

    Joined:
    Mar 20, 2018
    Posts:
    45
    @Jono_Unity

    Thank you for the help with Layer 3.
    I guess that was not the cause of the problem after all... :)


    It seems like I got the SimulatedDiscoveryMarkerProvider there...

    upload_2020-12-9_19-3-57.png


    In the Factory - I see a huge UI before starting
    upload_2020-12-9_19-10-41.png

    When I start the simulation - I see the UI in front of me down by the shelves.
    upload_2020-12-9_19-10-11.png

    If I switch to the kitchen - I see some UI even before starting.

    If that helps...
     
    Last edited: Dec 10, 2020
unityunity