Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. We've updated our Terms of Service. Please read our blog post from Unity CTO and Co-Founder Joachim Ante here
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

Known issue after importing Vuforia samples on 2018.1 & 2018.2

Discussion in 'Vuforia' started by meedabit, Jul 19, 2018.

  1. meedabit

    meedabit

    Official Vuforia Employee Vuforia

    Joined:
    Dec 8, 2016
    Posts:
    138
    Hello,

    Recently, Vuforia released 7.2 SDK with updated samples to the Unity Asset Store. These samples are not compatible with the 7.1 SDK, which is already packaged with most (if not all) of the current versions of the 2018.1 and 2018.2 Unity Editor.

    The most common Vuforia error message observed is the following: "The type or namespace name `FusionProviderType' could not be found. Are you missing an assembly reference?"

    This is a known issue that can be resolved by upgrading your Vuforia installation to 7.2 SDK. The simplest steps for doing this in the Unity Editor: Window->Vuforia Configuration->Download Vuforia 7.2.X

    A zip file will be downloaded via web browser to your machine. Run the executable in the zip and follow the prompts. Set the "Destination Folder" to where the version of the Unity Editor you are upgrading is installed on your machine. In my case, this is C:\Program Files\Unity_2018.1.8f1. Be sure to close the Unity Editor before installation.

    The installer will automatically update the Vuforia SDK. Reopen the project and note that the error message is now gone.

    We are actively looking into ways to avoid these types of issues, and make development with Vuforia as simple as possible.

    Thanks,
    Vuforia Engine Support
     
  2. tino1980

    tino1980

    Joined:
    Jan 18, 2013
    Posts:
    1
    Is there a different process for updating Vuforia on a mac?
     
  3. meedabit

    meedabit

    Official Vuforia Employee Vuforia

    Joined:
    Dec 8, 2016
    Posts:
    138
    Hello,

    To upgrade the version of Vuforia embedded in the Unity Editor, please follow these steps:
    1. Open the Unity Editor
    2. Select Window->Vuforia Configuration
      1. If there is an error message about Vuforia not being enabled, please follow the instructions and restart this process
    3. If your version of Unity is eligible for a Vuforia update, you'll see a message and link to download the installer
    4. Download and extract installer executable from downloaded ZIP file
    5. Run the installer executeable
      1. For Windows, select the folder that corresponds to the installed version of the Unity Editor that is eligible for the Vuforia update. Ex: C:\Program Files\Unity_2018.1.4f1
      2. For Mac, select the drive
        1. Note that for Mac, the installer executable will default to /Applications/Unity. This is a limitation of the Unity installer scripts. If you have multiple Unity application directories in this path, rename the target Editor version temporarily to /Applications/Unity to complete the installation
    6. Restart the same version of the Unity Editor in Step #1
    7. Verify the update in the Unity Editor via Window->Vuforia Configuration
    Thanks,
    Vuforia Engine Support
     
    rob_ice likes this.
  4. JDMulti

    JDMulti

    Joined:
    Jan 4, 2012
    Posts:
    381
    I've tried to update Vuforia within Unity 2018.2 to gain access to Vuforia 7.2. It shows me a link within the unity editor however the link inside the editor to update Vuforia only let me download a Vuforia 2018.1 update. I thought this was a typo and tried to install it but without success as the installer will tell me there is no Unity.exe found, which is not true but I guess the error meant that it isn't 2018.1 but 2018.2. Which is weird because I really downloaded Vuforia update within 2018.2 and not 2018.1.

    Can I ask why there is a Vuforia for Unity 2018.1 update inside a Unity 2018.2 version and how can I update to Vuforia 7.2 within Unity 2018.2?

    One of the things I couldn't get working was Model Targets, it worked perfectly inside the editor with a webcam but once I build to Android it doesn't show me a model target outline at all. It this feature broken, do I need this update or isn't it available for android with a developer license (temporary watermarked).
     
  5. meedabit

    meedabit

    Official Vuforia Employee Vuforia

    Joined:
    Dec 8, 2016
    Posts:
    138
    Hello @JDMulti,

    The installer name/version mismatch is just be a naming artifact issue - we should only have one installer artifact for both 2018.1 and 2018.2.

    I just confirmed that the 2018.1 installer package name works when upgrading 2018.2.2f1. Please note that on Mac, you need to insure that Editor version you are targeting for upgrade resides in /Applications/Unity. This can just be renamed temporarily during the upgrade.

    Thanks,
    Vuforia Engine Support
     
  6. deluise4

    deluise4

    Joined:
    Oct 21, 2017
    Posts:
    8
    Hello, meedabit. How do I override the naming artifact issue? I get the same error message when trying to update Vuforia for Unity 2018.2.1f1 on PC. Vuforia is working, but it's also saying I need to update it.
     
  7. meedabit

    meedabit

    Official Vuforia Employee Vuforia

    Joined:
    Dec 8, 2016
    Posts:
    138
    Hello @deluise4 ,

    Can you provide the error message you're seeing?

    I don't know if you have multiple versions of Unity installed on your PC (I do), but a common mistake that I've made is not selecting the correct install folder.

    Thanks,
    Vuforia Engine Support
     
  8. deluise4

    deluise4

    Joined:
    Oct 21, 2017
    Posts:
    8
    The message I kept getting was "Untiy.exe not found". I do have multiple versions, and I tried it with each folder, as well as renaming some folders. I downloaded 2018.1 and tried the installer and I didn't get the error message that time. I don't know what I did wrong, but I think I imported the Vuforia 6.2 assets (from my archives) into the project because the interface looked very old. I don't know. I went back into 2018.2 so I can just try to work the bugs out of my project.
     
  9. fabiotgarcia

    fabiotgarcia

    Joined:
    Apr 28, 2017
    Posts:
    23
    Hello!
    My tests with Vuforia 7.2.23 is not working in Unity 2028.2.2f1.
    Can you please send me a sample that works for you in these versions?
    I'd like to test it on my computer.

    Thanks,

    Fabio
     
  10. meedabit

    meedabit

    Official Vuforia Employee Vuforia

    Joined:
    Dec 8, 2016
    Posts:
    138
  11. fabiotgarcia

    fabiotgarcia

    Joined:
    Apr 28, 2017
    Posts:
    23
    Thank you!