Search Unity

  1. Unity 2019.1 is now released.
    Dismiss Notice

Keystore error

Discussion in 'Editor & General Support' started by soymuletz_mail, Feb 9, 2019.

  1. soymuletz_mail

    soymuletz_mail

    Joined:
    Feb 6, 2019
    Posts:
    1
    Hi all, I'm trying to build my project to an Android APK to publish it on Google Play. All good till it arrives to "Task packageRelease" where it says FAILED and it keeps giving me this error:
    I'm sure that all the passwords are correct. I never signed this project before with a keystore. Any help would be appreciated.
    Unity 2019.2.0a4

    EDIT: Also, if I create new keystore without changing the path and set it to the project if I try to set the password it will tell me "Wrong password" even if I write it correct and it shows me this error:

    Why does it try to access that path 2 times? If I try to manually edit the ProjectSettings.asset file with the absolute path of the keystore it works but gives me the first error.

    2EDIT: Solved! For those who have this kind of problem: When you create a password for the keystore, put it between ' ' so it will be like this 'password'. Note: only the keystore password! After you set it like this and created your new keystore, in the right panel you must type the password without the 2 ' ', so it will be like this password. After then, select your alias and type its password and then compile.
    I don't know why there is this bug. Unity adds to the command of keytool the 2 '' when they are not needed and it will tell you the password is wrong.
     
    Last edited: Feb 9, 2019
  2. dominykasm

    dominykasm

    Unity Technologies

    Joined:
    May 27, 2018
    Posts:
    40
  3. WILEz1975

    WILEz1975

    Joined:
    Mar 23, 2013
    Posts:
    288
    It is incredible that there is still this very serious error.
    I can't update my app and I'm losing a lot of money for it!
    My password is correct and the keystore is correct, I am 100% sure.
    But it continues to fail for this error.
    Since I switched to Unity 2018.2.2f1 form Unity 2017.
    It's incredible.
     
    jterragni likes this.
  4. roykoren

    roykoren

    Joined:
    Dec 23, 2018
    Posts:
    1
    I don't know why exactly, but it is probably connected somehow with insufficient space on disk.
    So I solved this issue by removing files from 'C://' (Had less than 150MB free). that's it.