Search Unity

Just curious: what's in Ubuntu that's missing from the underlying Debian?

Discussion in 'Linux Editor' started by ChanceEncounter, Jun 8, 2019.

  1. ChanceEncounter

    ChanceEncounter

    Joined:
    Dec 9, 2014
    Posts:
    7
    Debian is my daily driver, both as a dual-boot option and for the server in my closet. Debian-stable is hotfixes-only for years at a time, so I'm just wondering how we wound up in a situation where Ubuntu (built on Debian) is officially supported, but Debian is not.

    I don't know much about Ubuntu, though. It was my understanding that it's fundamentally just a superset, Debian for end users. Am I wrong?
     
  2. aboul

    aboul

    Joined:
    Apr 11, 2019
    Posts:
    1
    Hi, my 2 cents; Debian-stable ofen means old packages, where Ubuntu comes with recent ones ...
    (for me it's Debian testing, probably equivalent to an Ubuntu)
     
  3. Tautvydas-Zilys

    Tautvydas-Zilys

    Unity Technologies

    Joined:
    Jul 25, 2013
    Posts:
    6,364
    It's just more popular and we can't test and ensure every Linux distro out there works.
     
  4. nitrofurano

    nitrofurano

    Joined:
    Jun 7, 2019
    Posts:
    54
    no surprise that some of the distros we find at distrowatch are based on testing instead of stable
     
  5. ChanceEncounter

    ChanceEncounter

    Joined:
    Dec 9, 2014
    Posts:
    7
    I get that, but Ubuntu is built on Debian. I wouldn't expect you (or any rational person) to try to support even a handful of distros, but Ubuntu is a Debian-based system. They start with Debian and then they build stuff on top.

    That leaves me thinking that Unity might have a dependency that's part of Ubuntu, and I was wondering what that might be (if it exists.)
     
  6. Tautvydas-Zilys

    Tautvydas-Zilys

    Unity Technologies

    Joined:
    Jul 25, 2013
    Posts:
    6,364
    And they break stuff in the process :). You'd also expect Unity to work on Ubuntu 19.04 if we make sure it works on Ubuntu 18.04 yet that isn't the case due to changes to the default OS installation.

    We don't have any specific dependencies on Ubuntu as we also support CentOS with exact same binaries. However, we only declare to support what we test on.
     
  7. MostHated

    MostHated

    Joined:
    Nov 29, 2015
    Posts:
    735
    I had a few issues, but they are worked out now It was mostly the hub. I have had no issues with Unity itself on 19.04.