Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. We've updated our Terms of Service. Please read our blog post from Unity CTO and Co-Founder Joachim Ante here
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

[Jobs][Lags] JobTempAlloc has allocations that are more than 4 frames old

Discussion in 'Entity Component System and C# Job system' started by dyox, Jan 18, 2018.

  1. Hans-D

    Hans-D

    Joined:
    Sep 24, 2013
    Posts:
    26
    I'm glad the 4 frames limit on jobs is being removed, it's something that severely limits the use cases of jobs where they would otherwise be ideal. It also ties your code to the framerate, causing all sorts of "different hardware" problems. Say your job takes 30ms to finish; no bug at 60FPS, hard to track bug at 144FPS.
     
  2. LightYarn

    LightYarn

    Joined:
    Nov 18, 2012
    Posts:
    51
    After some research I found another case when this problem occurs. In our case while using WebGL and the Particle System..... kind of like @castor76 problem but slightly different.

    I'm using Unity 2018.3.0f2

    Here are some details of the bug-report

    EDIT: It's even simpler. Just publish an empty scene with fresh out-of-the-box particle system and (de)activate the Trail-Module. If active it will trigger the error.
     
    Last edited: Jan 4, 2019
  3. Marco-Trivellato

    Marco-Trivellato

    Unity Technologies

    Joined:
    Jul 9, 2013
    Posts:
    1,619
    Would you please submit a bug report and post the bug number here?
     
  4. EssencyStudios

    EssencyStudios

    Joined:
    May 18, 2018
    Posts:
    5
    I'm having this issue and between the hundreds of "JobTempAlloc has allocations that are more than 4 frames old.."
    it says "To Debug, enable the define: TLA_DEBUG_STACK_LEAK in ThreadsafeLinearAllocator.cpp. This will output the callstacks of the leaked allocations"

    Anyone figure out how to do this? I cant seem to.
    Here are some of those crash reports:

    one dude: https://pastebin.com/CcjPkuHj
    other dude: https://pastebin.com/Ce0TL821
    another dude: https://pastebin.com/CiNyXn04
     
  5. LightYarn

    LightYarn

    Joined:
    Nov 18, 2012
    Posts:
    51
    Peter77 likes this.
  6. LightYarn

    LightYarn

    Joined:
    Nov 18, 2012
    Posts:
    51
    Not fixed in 2018.3.1f1

    Build Target: WebGL
    Empty Scene -> New Particle System -> Active trails will trigger the error in build
     
  7. PieterAlbers

    PieterAlbers

    Joined:
    Dec 2, 2014
    Posts:
    98
    That is some sad news - was happy to see a new build today but looking at the release notes I was kinda let down :(