Search Unity

Bug Jetbrains Rider error "Advanced Unity Integration is unavailable" Unity 2022.3.3f1

Discussion in 'Code Editors & IDEs' started by swishchee, Sep 12, 2023.

  1. swishchee

    swishchee

    Joined:
    Jul 23, 2020
    Posts:
    63
    I am getting the following error using Rider: Screenshot 2023-09-12 at 12.54.05 PM.png

    In my Package Manager:
    upload_2023-9-12_12-58-59.png

    In my Unity settings:
    upload_2023-9-12_12-55-22.png

    So, what's up? I'm fulfilling all of the requirements stated in the error, yet the error persists. Obviously, my project-specific syntax highlighting and references are nonexistent.

    This is not the case for other unity projects.
     
  2. CodeSmile

    CodeSmile

    Joined:
    Apr 10, 2014
    Posts:
    5,841
    I get this complaint every now and then when launching Rider and gotten used to ignore it.

    I think if you let Rider finish its background tasks scanning all the project files it should go away.
     
  3. swishchee

    swishchee

    Joined:
    Jul 23, 2020
    Posts:
    63
    The above did not work for me, with the references continuing to be missing. The only way it solved itself for me was to go to Unity preferences -> external tools -> check every box having to do with packages -> "Regenerate project files".

    After doing this, all of the code ended up working for me, and I no longer got the "advanced unity integration" warnings. This is not something I've had to do previously, so I'm not sure what's going on this time.
     
  4. MelvMay

    MelvMay

    Unity Technologies

    Joined:
    May 24, 2013
    Posts:
    11,425
    Wrong forum. I'll move your thread.