Search Unity

  1. Are you interested in providing feedback directly to Unity teams? Sign up to become a member of Unity Pulse, our new product feedback and research community.
    Dismiss Notice

ITMS-90427: Invalid Swift Support

Discussion in 'iOS and tvOS' started by giggioz, Jul 26, 2021.

  1. giggioz

    giggioz

    Joined:
    May 11, 2017
    Posts:
    46
    XCode 12.4
    Unity 2020.1.5f1

    I (unfortunately, damn Apple) updated XCode and now I'm having issues trying to upload my app to the App Store.

    With the previous version of XCode I checked a build setting for swift => always embed but now I can not find it anymore.

    The closest thing that I found is

    upload_2021-7-26_12-40-34.png


    But, after the upload, I receive this email


    Dear Developer,

    We identified one or more issues with a recent delivery for your app, "QuesTavern - Febol!" 1.2 (12). Please correct the following issues, then upload again.

    ITMS-90427: Invalid Swift Support - The expected dylibs are missing from the app’s Framework location, such as /Payload/questavernfebol.app/Frameworks.

    Can someone help me with this?
    Thanks
     
  2. Neonlyte

    Neonlyte

    Joined:
    Oct 17, 2013
    Posts:
    355
    upload_2021-7-27_2-45-1.png
    Is this what you were looking for?
     
  3. giggioz

    giggioz

    Joined:
    May 11, 2017
    Posts:
    46
    Yes, it is, thanks, found it!
     
unityunity