Search Unity

  1. All Pro and Enterprise subscribers: find helpful & inspiring creative, tech, and business know-how in the new Unity Success Hub. Sign in to stay up to date.
    Dismiss Notice
  2. Dismiss Notice

item problem

Discussion in 'Editor & General Support' started by mozgov111poise, Sep 25, 2020.

  1. mozgov111poise

    mozgov111poise

    Joined:
    Sep 25, 2020
    Posts:
    3
    Hello. One problem that worries me is that there is too little detail in the unit. but for my game I need a high drawing range. A screenshot of the problem is attached:
     

    Attached Files:

  2. DiegoDePalacio

    DiegoDePalacio

    Unity Technologies

    Joined:
    Oct 28, 2009
    Posts:
    505
    Hello @mozgov111poise,

    Would you mind to explain in further detail what exactly you want to accomplish?

    I mean... What do you mean with "too little detail" or "high drawing range".

    Your explanation will help us to understand better your issue in order for us to help you ;)


    Thanks!
     
    Joe-Censored likes this.
  3. mozgov111poise

    mozgov111poise

    Joined:
    Sep 25, 2020
    Posts:
    3
    I need to increase the draw range of various renderers so that there is no blur too close
     
  4. Kayntt

    Kayntt

    Joined:
    Sep 4, 2020
    Posts:
    5
    I think you mean anisotropic filtering, you can change its settings in your camera
     
    DiegoDePalacio likes this.
  5. mozgov111poise

    mozgov111poise

    Joined:
    Sep 25, 2020
    Posts:
    3
    I think you need to look at the screenshot and see that the detail is lame and you need to do something about it
     
  6. DiegoDePalacio

    DiegoDePalacio

    Unity Technologies

    Joined:
    Oct 28, 2009
    Posts:
    505
    Hello @mozgov111poise,

    If what you're talking about is how bad or blurred your texture looks like when you look at it on a steep angle (as it is on you attached screenshot), then the suggestion from @Kayntt is what you should try.

    The anisotropic filtering is a method of enhancing the image quality of textures on surfaces that are at oblique viewing angles with respect to the camera. You can learn more about it here: https://en.wikipedia.org/wiki/Anisotropic_filtering

    You can adjust the anisotropic settings in the texture import settings: https://docs.unity3d.com/Manual/class-TextureImporter.html

    If you set the type of texture as "Default" type you'll be able to adjust the anisotropic level from 1 to 9.

    Try making this value higher for the texture that you're using on the ground ;)

    You can also check more information about anisotropic in Unity here: https://docs.unity3d.com/Manual/ImportingTextures.html#AnisotropicFiltering

    Finally, you can use Unity's Quality settings to force anisotropic filtering for all Textures or disable it completely: https://docs.unity3d.com/Manual/class-QualitySettings.html


    I hope this helps!
     
unityunity