Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Resolved Issues with Frame Hitching - Isolated ONLY to Unity Build/Editor& Unity Games by others (Solved)

Discussion in 'Editor & General Support' started by Cody-Rauh, May 5, 2020.

  1. Cody-Rauh

    Cody-Rauh

    Joined:
    Oct 12, 2013
    Posts:
    256
    WHEN YOU ARE WORKING 17-20 HOUR DAYS CAUSE A GLOBAL PANDEMIC HAS LITERALLY DESTROYED YOUR BUSINESS, AND TURNED YOUR LIFE UPSIDE DOWN....

    CHECK YOUR $(*&#(* INTERPOLATION!!!!

    Thank you Lecks for helping me with this!

    I literally cried at my computer at 2am, while listening to Skryim music, just thankful that things were finally running smoothly on my game, after a month of fixing and troubleshooting different things... well a multiple compound set of problems all interlaced.

    https://developer.nvidia.com/sites/default/files/akamai/gameworks/CN/Stuttering_Analysis_EN.pdf

    A video of the issue, Watch closely... I slow down intentionally and stop after every time the error occurs so you can rewind if necessary to help you see it better.

    Pay attention to the tree at 0:24 maybe even a little before to see how smooth it is before the error occurs.




    I am literally at wit's end at this point, I have to submit my demo for Steam Summer Festival in 4 days.

    For some reason, I have a problem that isn't affecting any of the other games installed on my computer, however, it affects every single Unity project I have, and even the Unity Learn projects.

    The word that was given to me was Hitch*, where things are going smoothly and then a visual detectable error occurs. Like it is snagging once in a while. I have spent over a month now trying to fix issues regarding smoothness during run time.

    Additionally, objects moving on screen, even particles have this hitch, even if player and camera isn't moving. It is very slight but still noticeable. When moving though it can be very obvious.

    I have corrected and had my code reviewed for both camera & player movement (It wouldn't make sense to me that camera controller or player controller is the issue, especially in the Unity Learn projects where the Unity team programmed the movement.), I have updated my graphics driver, tried turning on and off vsync settings, tried finding the problem in my Unity profiler.

    I just don't know what to do anymore, I am really afraid I will be stuck in this same place with this same problem 3 months from now if I don't get help.
     
    Last edited: May 6, 2020
  2. Cody-Rauh

    Cody-Rauh

    Joined:
    Oct 12, 2013
    Posts:
    256
    System Information:

    Processor:
    AMD Ryzen 7 3800X Processor (8x 3.9GHZ/32MB L3 Cache)
    Motherboard:
    ASUS TUF X470-PLUS GAMING
    Memory:
    16 GB [8 GB X2] DDR4-3000 Memory Module
    Video Card:
    NVIDIA GeForce GTX 1650 - 4GB GDDR5
    Primary Hard Drive:
    512 GB Intel 660p M.2 NVMe SSD
    Secondary Hard Drive:
    1 TB 7200RPM Hard Drive
    3rd Hard Drive:
    2 TB SEAGATE HARD DRIVE 7200RPM

    Previous Troubleshooting Documentation:
    https://forum.unity.com/threads/pixel-perfect-camera-darn-dancing-walls-solved.872314/
    https://forum.unity.com/threads/camera-update-precision-issue-not-fps-drop.881893/

    Updates will continue as available.

    - Graphics Drivers up to date - 5.5.2020
    - Windows 10 OS 64 up to date - 5.5.2020
    - Vsync off/on no impact
    - Impacts HDRP/URP/ and Standard Render Pipelines equally.
    - Impacts multiple versions of Unity.
    - Impacts other Unity games by other developers on Steam (does not impact non-unity games)!!! dafuq?
    - Have uninstalled/Reinstalled Unity
     
    Last edited: May 5, 2020
  3. Cody-Rauh

    Cody-Rauh

    Joined:
    Oct 12, 2013
    Posts:
    256
  4. Cody-Rauh

    Cody-Rauh

    Joined:
    Oct 12, 2013
    Posts:
    256
  5. qq0457

    qq0457

    Joined:
    Jul 26, 2020
    Posts:
    1
    Hey, bro. I came into this issue too and read all your discuss. But I still can't locate the root source of the issue in my project. Can you tell me how you solve this issue finally ?