Search Unity

Resolved Issues building almost empty Tiny Android project (shader compiler error)

Discussion in 'Project Tiny' started by Vari-Mods, Feb 22, 2021.

  1. Vari-Mods

    Vari-Mods

    Joined:
    Jan 21, 2021
    Posts:
    7
    Hi,

    I just started using Tiny Project as a base for my game. I followed the documentation about what to install, how to setup the Assembly reference and the build script and so on.
    The document suggested to Create a Scene, add a camera and a cube and give it a try to build the application using the DotsruntimeBuildConfiguration. I set the target to Android et voilá ... I always get the same error.

    I already tried to remove GLES from Player-Settings but as I checked the code, this is something specified inside the Tiny-Code. There is also the reference to GLES2.0, not event GLES3.x

    Console.JPG

    The logs are:
    UnityShaderCompilerLog:
    I don't have an idea about that.

    conversionLog:
    Does anyone have an idea whats wrong with my setup?

    Unity 2020.2.5f1
    Tiny Project Version 0.32.0-preview.55
    Target Android

    Thanks for the support :)
     
  2. Vari-Mods

    Vari-Mods

    Joined:
    Jan 21, 2021
    Posts:
    7
    Ok obviously this was a wrong setup with my Visual Studio 2019, missing the Windows 10 SDK components.
    Crazy thing. After I managed to get am example project running on window and Android (Tiny Factory), I tried to create a new project from scratch again following the DOTS/Tiny Project documentation.

    After dealing with some minor setting issues, not working out of the box while following the documentation, I made it and got it running on my Android.
    So for me it was linked to the missing compontent(s) in Visual Studio 2019
     
  3. AbdulAlgharbi

    AbdulAlgharbi

    Unity Technologies

    Joined:
    Jul 27, 2018
    Posts:
    319
    Make sure you are on unity 2020.1.x
    Tiny 0.32 doesn't support unity 2020.2
     
    Djo_krd, Daxode and Vari-Mods like this.
  4. Vari-Mods

    Vari-Mods

    Joined:
    Jan 21, 2021
    Posts:
    7
    Ah yes, Meanwhile I am using 2020.1.17f1
     
unityunity