Search Unity

  1. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Let us know a bit about your interests, and if you'd like to become more directly involved. Take our survey!
    Dismiss Notice
  4. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  5. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Issue: Particles not visible on certain angles

Discussion in 'General Graphics' started by Polkatuba, Apr 20, 2015.

  1. Polkatuba

    Polkatuba

    Joined:
    Oct 31, 2014
    Posts:
    73
    Greetings,

    I'm trying to create a meteor shower effect in Unity 5 using particle system.
    However I'm experiencing an issue which is ruining everything. When the particle effect is viewed on certain angles, it completely disappears, and then pops up back again when the camera angle changes.

    Please see the attached image (animated gif):

    Particles.gif

    The particle system is set to operate in world space. So culling should not happen.
    Adding another camera to the particle system is waste of time also. Nothing changes.

    I have found several discussions of this same issue around the net. It is very unfortunate to see that this was first reported in year 2011:


    Why it has not been fixed, is there some technical limitation?
    How can I fix this?

    Thanks
     
    Last edited: Apr 20, 2015
    dichardson likes this.
  2. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    23,350
    For world space, simply parent the particle system to the camera and it ought to be fine. It will indeed cull out of bounds. Not sure if bug or not but the resolution for us is to either parent to camera or move it to where the effect will play.
     
  3. Polkatuba

    Polkatuba

    Joined:
    Oct 31, 2014
    Posts:
    73
    Thanks for your reply, hippocoder.

    I have tried to parent it to camera, but unfortunately it makes absolutely no difference.

    With or without the camera, the particle system says: "Automatic culling is disabled because world space simulation is used. Emission is distance based". So it should work already, even though it doesn't?

    Particles.jpg
     
    Last edited: Apr 20, 2015
  4. varfare

    varfare

    Joined:
    Feb 12, 2013
    Posts:
    220
    It is a known and reported bug which I have encountered back in 2012. It is still present in 2015. The problem is that Unity calculates particle bounds automatically and you cannot modify it in any way. It is not exposed for scripting. Sometimes, it does not matter if your simulation is in world space or local space - particles are just being culled. Possible alternative solutions:
    1. None.
    2. Vote for resolving this bug on issue tracker and wait few more years for Unity devs taking care of it.

    http://issuetracker.unity3d.com/issues/shuriken-is-culling-particles-when-were-using-setparticles
    http://issuetracker.unity3d.com/issues/incorrect-culling-when-using-mesh-rendering-with-shuriken
    http://unity3d.com/search?refinement=issues&gq=shuriken culling
     
    lifeisfunxyz likes this.
  5. Polkatuba

    Polkatuba

    Joined:
    Oct 31, 2014
    Posts:
    73
    Thanks varfare,

    That was the reply I was afraid of. It's very frustrating when things like these come into your way and prevent you from doing what you planned. And even more when there is nothing you can do about it.

    I voted, if that helps anything.
     
  6. Polkatuba

    Polkatuba

    Joined:
    Oct 31, 2014
    Posts:
    73
    Ok, I was able to circumvent the bug. In this case, as the soot is raining down from sky, I had to make an emiter long enough to reach the ground level. Now there is no culling anymore. I hope this helps someone.
     
    varfare and theANMATOR2b like this.
  7. krisventure

    krisventure

    Joined:
    Mar 24, 2016
    Posts:
    44
    As of 2016 with Unity 5.4 I've got a similar problem but found a quick fix. This particle system got culled incorrectly just like yours no matter what stimulation space I used. Interestingly though, simply increasing the particle size property within the ParticleSystem component and proportionally decreasing the scale in transform SOLVED it.

    In other words, in some cases scaling the transform instead of the particle size, or perhaps having too small particle size while large transform, will not allow correct bound detection and culling behavior. Hope this helps.
     
  8. richardkettlewell

    richardkettlewell

    Unity Technologies

    Joined:
    Sep 9, 2015
    Posts:
    772
    If you can report a bug to us with this new reproduction case, we will see if we can fix the underlying issue.
    I've double-checked the other previously raised issues and they all should be fixed in Unity 5.4.
     
  9. dichardson

    dichardson

    Joined:
    Oct 7, 2017
    Posts:
    63
    I ran into this problem today (I'm on 2017.3) and found out it was due to the particle effect playing outside the particle effects bounds. To see if this is happening, you need to enable "Show Bounds" while the particle effect is selected in the Hierarchy window.

    I'm not yet sure why this is happening in my specific case, but I have tracked it down to interaction with an IK system I'm using that does changes after Update.

    No Effect.PNG
     
  10. dichardson

    dichardson

    Joined:
    Oct 7, 2017
    Posts:
    63
    Update on my last post. I filed a bug for the above problem (reported in 2017.3) and found out it was already fixed in 2018.1 beta. I confirmed the problem was fixed in 2018.1.0b9.
     
  11. kanda76

    kanda76

    Joined:
    Sep 4, 2013
    Posts:
    15
    Unity 2017.3.1f1: we've got a similar problem as dichardson.
    We have a particle system attached to an item. The item is attached to the hand of biped character: the bounds of the particle system are totally wrong, see the picture:

    As you can see the yellow box is wrong location, approximately 1 meter away from the particles. And in render view, the particles don't appear. Particles scale option is set to hierarchy. There is a 0.1 scale on the parent of the particle system's gameobject.