Search Unity

Tile Map Isometric tile palette render issue

Discussion in '2D Experimental Preview' started by Leonard1985, Apr 9, 2019.

  1. Leonard1985

    Leonard1985

    Joined:
    Jul 24, 2014
    Posts:
    2
    After switching the platform once, my project became like this:



    My Unity version is 2018.3.11f1
     
  2. ChuanXin

    ChuanXin

    Unity Technologies

    Joined:
    Apr 7, 2015
    Posts:
    303
    Hi, could you please file a bug report using the Unity Bug Reporter with this project and post the bug number here? Thanks!

    Also, are you using the 2D Animation package inside your project? There is an issue with the TilemapRenderer related to this with the 2D Animation package.
     
    Brogan89 likes this.
  3. Leonard1985

    Leonard1985

    Joined:
    Jul 24, 2014
    Posts:
    2
    OK, I tried to remove the 2D Animation package and the issue was fixed.
     
  4. Pozonu

    Pozonu

    Joined:
    Jul 27, 2014
    Posts:
    5
    I have the exact same issue, but using the normal non-isometric view. I'm also using the 2D Animation package which is likely the problem, however I can't do without that package since I've already used it for a lot of my project.

     
  5. ChuanXin

    ChuanXin

    Unity Technologies

    Joined:
    Apr 7, 2015
    Posts:
    303
    Sorry about this, there will be a bug fix for this in a future Unity version.
     
    teh1person0, Brogan89 and Pozonu like this.
  6. Brogan89

    Brogan89

    Joined:
    Jul 10, 2014
    Posts:
    152
  7. ChuanXin

    ChuanXin

    Unity Technologies

    Joined:
    Apr 7, 2015
    Posts:
    303
    If it does not seem like it is caused by the interaction between the TilemapRenderer and the 2D Animation package, please do file a bug (or if you are uncertain, please do too).

    Based on your thread, it does look like the problem with the TilemapRenderer and the 2D Animation package, so maybe not?
     
  8. Triband

    Triband

    Joined:
    Apr 30, 2016
    Posts:
    3
    This is still not fixed in 2019.1.2f
     
  9. ito123456789

    ito123456789

    Joined:
    Jan 29, 2015
    Posts:
    7
    Will this be fixed for 2018.3.4 as well?