Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Is there any way to change the site language permanently?

Discussion in 'Meta-forum Discussion' started by FPires, May 4, 2017.

  1. FPires

    FPires

    Joined:
    Jan 5, 2012
    Posts:
    151
    Every time I have to visit the site I'm presented with a page in Portuguese by default. And since I'm always keeping a secondary up-to-date Unity installation to check the news, this happens very often. The enforced language setting is pointless because the actual patch notes aren't translated, and even even if they were I'd prefer to read the resources in plain English since that's the language in which most of the Unity content is written. On top of that the pages are written in European Portuguese, not Brazilian Portuguese, filled with terms I'm not familiar. Needless to say I am not exactly happy with being IP-locked to a language.

    So I change the language to English and the cookies stick for a day or two before reverting to Portuguese. This is the only site wherein this happens - I don't have this issue with any other site with a language option.

    It's profoundly annoying. I'm using the latest version of Chrome. This has been going on for a year or so.
     
    CodeSmile and Arendant like this.
  2. luiks

    luiks

    Joined:
    Aug 23, 2017
    Posts:
    15
    I have the same issue, did you find any solution?? my page is in German!?
     
  3. Syfied

    Syfied

    Joined:
    May 8, 2020
    Posts:
    1
    At the bottom right of the webpage, there should be drop down selector for the language. Hope that helps @Lukis.
     
  4. Curse-Ka

    Curse-Ka

    Joined:
    Jan 18, 2021
    Posts:
    1
    Thank goodness this thread exists. Mine was in KOREAN! I was so lost
     
  5. trsell

    trsell

    Joined:
    Aug 8, 2021
    Posts:
    1
    I live in Singapore and no matter how often I change the site to English, the next day I come back and it defaults to Chinese again.
     
    CodeSmile likes this.
  6. CodeSmile

    CodeSmile

    Joined:
    Apr 10, 2014
    Posts:
    5,015
    Super-annoying!

    A work around I found is to install ModHeader extension and enter these settings (pic + text for copy/paste):

    Accept-Language
    en-US;q=0.7,en;q=0.6

    upload_2021-11-6_11-12-26.png

    This forces all sites to english.
     
    Last edited: May 3, 2023
    danielpanfw likes this.
  7. danielpanfw

    danielpanfw

    Joined:
    Jul 24, 2022
    Posts:
    1
    I tried and this works super well. Thank you!!!!
     
  8. incompreneur

    incompreneur

    Joined:
    Mar 24, 2023
    Posts:
    3
    It's possible that the Unity website is using cookies to remember your language preference, but for some reason, the cookies are not sticking. One thing you could try is to clear your browser's cookies and cache and then set the language preference to English again. If the problem persists, you could try using a different browser or contacting Unity's customer support to see if they can assist you.

    It's also worth noting that some websites may use your IP address to determine your location and language preference. If you're accessing the website from a different location than usual, this could be why the language preference is reverting to Portuguese. In this case, you could try using a VPN to access the website from your usual location and see if that helps.
     
  9. Ryiah

    Ryiah

    Joined:
    Oct 11, 2012
    Posts:
    20,711