Search Unity

Is Kudan-AR-sdk available for smart glasses such as Moverio BT-350?

Discussion in 'AR' started by tedyage, Jul 19, 2018.

  1. tedyage

    tedyage

    Joined:
    Jun 27, 2018
    Posts:
    1
    Unity Version:5.6.0; SDK Version:1.5.1;

    Lately, I downloaded the Kudan-Unity-SDK for augmented reality development. I've created a project and imported the package. And then I configurated both the Editor key and the API key correctly.

    So I ran the KudanSample on the whole of my android devices, which was within the sdk package. I had two smart phones and one smart glasses, note that my glasses is Epson Moverio BT-350. Those two smart phones could run that sample properly, but in that smart glasses, the GUI showed that tracker is not running and the view didn's show anything but the UI layer.

    I tracked the code and found the exception point, which happened when the code
    "AndroidJavaClass kudanArClass = new AndroidJavaClass("eu.kudan.androidar.KudanAR");"
    executed. So I was wondering, Is this sdk available on the glasses device?

    It will be a great favor if there is someone could help me with it.

    Greate appreciate.

    The content of the exception mentioned before is the image below:
     

    Attached Files: