Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Bug iOS framework addition failed due to a CocoaPods installation failure.

Discussion in 'macOS' started by ngqbac, Oct 19, 2023.

  1. ngqbac

    ngqbac

    Joined:
    Jan 8, 2019
    Posts:
    4
    My project using Firebase Auth, GoogleSignIn 1.0.4 and AppleSignIn. It's work fine when using Xcode 14 and Unity 2021 LTS to build in Mac mini M1 Ventura. But when update to Sonoma, Xcode 15 and Unity 2022.3.10f1, i got this error but in console build result still 'Succeeded'

    After Unity build succeeded, i edit pod 'Firebase/Auth' and pod 'Firebase/ Core' to '>= 9.6.0' then run pod install. Then i run "Unity-iPhone.xcworkspace" then build with instruction of AppleSignIn but i got this error

    My pod file

    Is anyone got this error or find something can fix it? My project already published in Appstore and i want to update but cant build it :(
     
  2. sokolwow

    sokolwow

    Joined:
    Dec 19, 2012
    Posts:
    3
    I have the same problem and don't understand what to do
    Sonoma, XCode 15, Unity 2021.3.31f1


    Undefined symbols:
    Linker command failed with exit code 1 (use -v to see invocation)
     
  3. pei114

    pei114

    Joined:
    Oct 11, 2021
    Posts:
    3
    Do you have a solution to this problem :((