Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

IOs AdMob and XCode 7 beta: Module not found?

Discussion in 'iOS and tvOS' started by DubStepMaster, Aug 17, 2015.

  1. DubStepMaster

    DubStepMaster

    Joined:
    Jul 17, 2012
    Posts:
    40
    Hey there,

    I have build my project with Unity 5.1.0.f.3 and use the XCode 7 beta 7A120f version to run my app an my phone. Now the problem is, that I added the Google Mobile Ads Unity Plugin v2.2 and the iOS Google Mobile Ads SDK v7 and set it up.

    When I hit compile, XCode throughs the error "Module 'GoogleMobileAds' not found"

    Anyone an idea, why this won't work?

    Thank you :)
     
  2. DubStepMaster

    DubStepMaster

    Joined:
    Jul 17, 2012
    Posts:
    40
    found the solution: had to add "$(PROJECT_DIR)" without " to the Framework - , Header - and Libary search paths in the buildsettings in XCode.
     
    Casas-Maestre likes this.
  3. zigglr

    zigglr

    Joined:
    Sep 28, 2015
    Posts:
    82
    Could you go into more detail as to what you changed the framework, header and library search paths to? Seems Admob is completely broken after xcode 7
     
  4. vanshika1012

    vanshika1012

    Joined:
    Sep 18, 2014
    Posts:
    34
    Add this -> $(PROJECT_DIR) under search path in build setting to framework path , header path and library path.
     
  5. manny003

    manny003

    Joined:
    Mar 18, 2014
    Posts:
    67
    I've have very minimal experience managing Xcode projects -- could you perhaps provide screenshots? I'm having a hard time.

    Thanks bunches.
     
  6. manny003

    manny003

    Joined:
    Mar 18, 2014
    Posts:
    67
    Ok. I'm at the of my rope. Nothing is working. I'm using Unity 5.2.4f1, Xcode 7.2.1. I just installed the latest version of the Google Mobile Ads Plugin v3.0.1 (https://github.com/googleads/googleads-mobile-unity/releases/tag/v3.0.1) and for the life of me, I simply can't build.

    I made the settings changes, cleaned my project and tried to build but I still get the same error.

    Can anyone help? Here are screen shot of my settings:

    Screen Shot 2016-02-18 at 11.05.34 PM.png Screen Shot 2016-02-18 at 11.05.58 PM.png Screen Shot 2016-02-18 at 11.05.58 PM.png Screen Shot 2016-02-18 at 11.06.16 PM.png Screen Shot 2016-02-18 at 11.06.37 PM.png
     
  7. bphillips09

    bphillips09

    Joined:
    Aug 31, 2014
    Posts:
    33
    Did you get this figured out? I'm having the exact same issue as of today. It's never happened before today.
     
  8. SpiralB

    SpiralB

    Joined:
    Feb 18, 2016
    Posts:
    1
    I had trouble figuring this out too but realized I forgot to add the google mobile ads framework to Xcode in addition to adding the plugin in Unity. Make sure you see it under the "Frameworks" section in the Xcode files. Hope this helps!
     
    Tony-Sparrow likes this.
  9. bphillips09

    bphillips09

    Joined:
    Aug 31, 2014
    Posts:
    33
    I ended up adding the framework before I saw this post. Thanks! Also, however, I'm finding that sometimes banner advertisements don't get destroyed or hidden when .Hide or .Destroy is called, but only on iOS. I read somewhere that this issue was fixed about a year ago, but I have the most recent version of the Google Ads SDK and am still having this issue. Is anyone else?
     
    Tony-Sparrow likes this.
  10. gilianp

    gilianp

    Joined:
    Mar 24, 2014
    Posts:
    4
    When importing .framework in xcode, you can check "copy if needed", so automatically " $(PROJECT_DIR)" will be added in Framework, Header and Lybrary search paths
     
  11. vexe

    vexe

    Joined:
    May 18, 2013
    Posts:
    635
    Having the same issue here. Where do I find this "GoogleMobAds.framework" file?
     
  12. IKCStudio

    IKCStudio

    Joined:
    Oct 2, 2014
    Posts:
    1
    It's not included, nor is it mentioned in the guide. I don't know where other people are getting the framework, but I got it by simply downloading the Admob SDK for iOS: https://developers.google.com/admob/ios/download
    Fingers crossed whether it works or not o_O
     
  13. vexe

    vexe

    Joined:
    May 18, 2013
    Posts:
    635
    @lankmanapps Yeah I eventually downloaded that, added the 'framework' but still didn't help much... Any luck on your end?
     
  14. Haktic

    Haktic

    Joined:
    Jun 1, 2016
    Posts:
    1
    I am getting same problem, downloaded sdk but still no solution, any help ?
     
  15. Sam-K

    Sam-K

    Joined:
    Mar 23, 2013
    Posts:
    27
    I had the same issue added GoogleAds Framework. Now i'm getting an error in the Xcode Console
    NSURLSession/NSURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -9814)
    when the LoadAd function is called. I have doubled checked my IOS ID ca-app-pub-1219365107499960/2375676139.
    Anyone solved this?
     
  16. litebox

    litebox

    Joined:
    Aug 29, 2011
    Posts:
    118
    This helps, thank you.
     
  17. karim7

    karim7

    Joined:
    Mar 8, 2015
    Posts:
    4
    fix the problem
     
  18. swifer07

    swifer07

    Joined:
    May 27, 2013
    Posts:
    12