Search Unity

  1. Calling all beginners! Join the FPS Beginners Mods Challenge until December 13.
    Dismiss Notice
  2. It's Cyber Week at the Asset Store!
    Dismiss Notice

iOS 4.3 App Rejected

Discussion in 'iOS and tvOS' started by glenwn, Mar 24, 2011.

  1. minevr

    minevr

    Joined:
    Mar 4, 2008
    Posts:
    1,015
    I get it,used Xcode 3.2.5

    Confusing....
     
  2. RazorCut

    RazorCut

    Joined:
    May 7, 2009
    Posts:
    394
    For what it's worth, I am getting a similar FMOD-like crash report, but only from iPhone 2nd gen and iPod 2nd gen. These are test-devices only, so are pretty bare bones:

    Code (csharp):
    1.  
    2. Thread 0 Crashed:
    3. 0   libSystem.B.dylib               0x00089320 __kill + 8
    4. 1   libSystem.B.dylib               0x0008930e kill + 4
    5. 2   libSystem.B.dylib               0x00089302 raise + 10
    6. 3   libSystem.B.dylib               0x000a004e abort + 54
    7. 4   hh2                             0x01190438 FMOD::SystemI::createChannelGroupInternal(char const*, FMOD::ChannelGroupI**, bool, bool) + 1428512
    8. 5   hh2                             0x011a4ee0 FMOD::SystemI::createChannelGroupInternal(char const*, FMOD::ChannelGroupI**, bool, bool) + 1513160
    9. 6   libSystem.B.dylib               0x00087cd0 _sigtramp + 28
    10. 7   libSystem.B.dylib               0x0008930e kill + 4
    11. 8   libSystem.B.dylib               0x00089302 raise + 10
    12. 9   libSystem.B.dylib               0x000a004e abort + 54
    13. 10  hh2                             0x0126b534 FMOD::SystemI::createChannelGroupInternal(char const*, FMOD::ChannelGroupI**, bool, bool) + 2325788
    14. 11  hh2                             0x0126b574 FMOD::SystemI::createChannelGroupInternal(char const*, FMOD::ChannelGroupI**, bool, bool) + 2325852
    15. 12  hh2                             0x01187970 FMOD::SystemI::createChannelGroupInternal(char const*, FMOD::ChannelGroupI**, bool, bool) + 1392984
    16. 13  hh2                             0x01191e70 FMOD::SystemI::createChannelGroupInternal(char const*, FMOD::ChannelGroupI**, bool, bool) + 1435224
    17. 14  hh2                             0x00c6a6a4 start + 13005620
    18. 15  hh2                             0x00ba2ea8 start + 12188472
    19. 16  hh2                             0x00bc1840 start + 12313808
    20. 17  hh2                             0x0118300c FMOD::SystemI::createChannelGroupInternal(char const*, FMOD::ChannelGroupI**, bool, bool) + 1374196
    21. 18  hh2                             0x01214a90 FMOD::SystemI::createChannelGroupInternal(char const*, FMOD::ChannelGroupI**, bool, bool) + 1970808
    22. 19  hh2                             0x011c75e4 FMOD::SystemI::createChannelGroupInternal(char const*, FMOD::ChannelGroupI**, bool, bool) + 1654220
    23. 20  hh2                             0x011a6810 FMOD::SystemI::createChannelGroupInternal(char const*, FMOD::ChannelGroupI**, bool, bool) + 1519608
    24. 21  hh2                             0x011a7d4c FMOD::SystemI::createChannelGroupInternal(char const*, FMOD::ChannelGroupI**, bool, bool) + 1525044
    25. 22  hh2                             0x011846e0 FMOD::SystemI::createChannelGroupInternal(char const*, FMOD::ChannelGroupI**, bool, bool) + 1380040
    26. 23  hh2                             0x011865d8 FMOD::SystemI::createChannelGroupInternal(char const*, FMOD::ChannelGroupI**, bool, bool) + 1387968
    27. 24  hh2                             0x00ef8c40 start + 15685840
    28. 25  hh2                             0x00f740f0 start + 16190848
    29. 26  hh2                             0x00003718 start + 936
    30. 27  hh2                             0x00cfa780 start + 13595664
    31. 28  hh2                             0x00cf70fc start + 13581708
    32. 29  UIKit                           0x000133c8 -[UIApplication _callInitializationDelegatesForURL:payload:suspended:] + 1108
    33. 30  UIKit                           0x00005b6c -[UIApplication _runWithURL:payload:launchOrientation:statusBarStyle:statusBarHidden:] + 292
    34. 31  UIKit                           0x0007dd74 -[UIApplication handleEvent:withNewEvent:] + 1784
    35. 32  UIKit                           0x0007d470 -[UIApplication sendEvent:] + 60
    36. 33  UIKit                           0x0007ccf8 _UIApplicationHandleEvent + 6804
    37. 34  GraphicsServices                0x00005dd8 PurpleEventCallback + 1024
    38. 35  CoreFoundation                  0x00035e40 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE1_PERFORM_FUNCTION__ + 22
    39. 36  CoreFoundation                  0x00035dfe __CFRunLoopDoSource1 + 158
    40. 37  CoreFoundation                  0x0002809e __CFRunLoopRun + 574
    41. 38  CoreFoundation                  0x00027d74 CFRunLoopRunSpecific + 220
    42. 39  CoreFoundation                  0x00027c82 CFRunLoopRunInMode + 54
    43. 40  UIKit                           0x00004f64 -[UIApplication _run] + 524
    44. 41  UIKit                           0x000024cc UIApplicationMain + 964
    45. 42  hh2                             0x000049d8 start + 5736
    46. 43  hh2                             0x0000339c start + 44
    47.  

    Hardware Model: iPhone1,2
    OS Version: iPhone OS 4.1 (8B117)

    Hardware Model: iPod2,1
    OS Version: iPhone OS 4.0 (8A293)

    This crash does not occur on models later than this. I am using the OpenFeint plugin, but I have removed all calls to UnitySetAudioSessionActive(), which made a previously related crash go away when suspending/resuming the game but this one still persists.

    I fear uploading my entire project at the moment, so perhaps this little tidbit will help shed some light? If not, then I'll have to go ahead and try to upload the multi-gig project I suppose.
     
  3. clinton_d

    clinton_d

    Joined:
    Feb 11, 2011
    Posts:
    17
    Hi. I'm quite new to Unity so be gentle!

    Three months of development time on my first app, for it to be rejected by Apple for reasons mentioned above (crashes within their review environment).

    I was lost for three days trying to understand the problem and even logged an Apple support request. However after some more digging I discovered this thread and now feel confident it is a Unity>XCODE4 issue.

    Env:

    XCODE 4
    SDK 4.3
    Unity 3.3

    Strange thing is, app works perfectly in my env across 4 devices. Also works fine on remote adhoc devices (tested on 3x remote units). I build only ARM6 however as ARM7 appears to invoke OpenGL2 regardless of my settings (including editing AppController.mm), which runs at 4fps or so on my iPad.

    Symbolicated snippet (from the review team crashlog):

    Exception Type: EXC_BAD_ACCESS (SIGBUS)
    Exception Codes: KERN_PROTECTION_FAILURE at 0x00000000
    Crashed Thread: 0

    Thread 0 name: Dispatch queue: com.apple.main-thread
    Thread 0 Crashed:
    0 breeze 0x019ee6e4 rehash + 128
    1 breeze 0x019eebb0 g_hash_table_insert_replace + 100
    2 breeze 0x0190bf98 mono_aot_register_module + 304
    3 breeze 0x01590430 RegisterMonoModules() (RegisterMonoModules.cpp:27)
    4 breeze 0x00004ab8 main (main.mm:11)
    5 breeze 0x00002760 start + 32

    Im going to revert to older xcode and resubmit to Apple.

    Posting here to hopefully assist others who might be seeing the same issues.

    Thanks for the thread, my headache just disappeared ...
     
    Last edited: Apr 6, 2011
  4. Mantas-Puida

    Mantas-Puida

    Unity Technologies

    Joined:
    Nov 13, 2008
    Posts:
    1,851
    Thanks for posting this. It follows the same pattern as others reported. We are communicating Apple to get this problem resolved.
    We will let you know when any news are available. As mentioned in the thread above workaround is to downgrade to the iOS SDK 4.2.
     
  5. clinton_d

    clinton_d

    Joined:
    Feb 11, 2011
    Posts:
    17
    Hi Mantas.

    Thanks for the update.

    Is it simply a case of switching the SDK within Unity to 4.2, or is xcode3.2.5 a requirement?

    Thanks.

    clinton.
     
  6. spinaljack

    spinaljack

    Joined:
    Mar 18, 2010
    Posts:
    892

    You should always release your game with fast but no exceptions. Slow and safe is for debugging.
     
  7. Mantas-Puida

    Mantas-Puida

    Unity Technologies

    Joined:
    Nov 13, 2008
    Posts:
    1,851
    You should reinstall whole iOS SDK 4.2+xcode bundle. Setting different SDK in Unity Player Settings won't do the thing.
     
  8. danielsonchris

    danielsonchris

    Joined:
    Feb 12, 2011
    Posts:
    43
    So you mean to re-install with XCode 3.2.5 or can we install with the latest XCode 3.2.6? Thanks in advance.
     
  9. danielsonchris

    danielsonchris

    Joined:
    Feb 12, 2011
    Posts:
    43
  10. BasketQase

    BasketQase

    Joined:
    Sep 12, 2005
    Posts:
    97
    Just had the same rejection notice. Annoying, but glad that I'm not the only one.

    Code (csharp):
    1.  
    2.  
    3. Date/Time:       2011-04-06 15:07:29.817 -0800
    4. OS Version:      iPhone OS 4.3.1 (8G4)
    5. Report Version:  104
    6.  
    7. Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
    8. Exception Codes: KERN_INVALID_ADDRESS at 0xeb6072f4
    9. Crashed Thread:  0
    10.  
    11. Thread 0 name:  Dispatch queue: com.apple.main-thread
    12. Thread 0 Crashed:
    13. 0   scrambledios                    0x01a3193c 0x1000 + 27461948
    14. 1   scrambledios                    0x01950688 0x1000 + 26539656
    15. 2   scrambledios                    0x015b7d2c 0x1000 + 22768940
    16. 3   scrambledios                    0x00003724 0x1000 + 10020
    17. 4   scrambledios                    0x000021c0 0x1000 + 4544
    18.  
    The SDK downgrade is the only working solution right now?

    Thanks,
    ~Rob
     
  11. Mantas-Puida

    Mantas-Puida

    Unity Technologies

    Joined:
    Nov 13, 2008
    Posts:
    1,851
  12. swiv

    swiv

    Joined:
    Mar 22, 2009
    Posts:
    30
    Where can I get a hold of 4.2? On the Apple dev site I can only find links to 4.3?
     
  13. danielsonchris

    danielsonchris

    Joined:
    Feb 12, 2011
    Posts:
    43
    @mantasp Thanks for the follow-up. So I'll assume then that XCode 3.2.5 then which would contain the version 4.2. (As I remember).
     
  14. Deleted User

    Deleted User

    Guest

    Where i can download Xcode 3.2.5?

    From Apple i can download only Xcode 3.2.6

    Thank you
     
  15. danielsonchris

    danielsonchris

    Joined:
    Feb 12, 2011
    Posts:
    43
  16. Deleted User

    Deleted User

    Guest

  17. nikemerlino

    nikemerlino

    Joined:
    Jul 2, 2008
    Posts:
    66
    app rejected.
    downgrade to xcode 3.2.5 ios 4.2
    I'm waiting for the new review, I will tell you
     
  18. danielsonchris

    danielsonchris

    Joined:
    Feb 12, 2011
    Posts:
    43
    @Andrea No problem.

    @nikemerlino let us know if it works! I'm about 4 weeks out from a release myself! Wishing you the best.
     
  19. ThinkTank

    ThinkTank

    Joined:
    Aug 5, 2010
    Posts:
    25
    I was approved today, Friday April 8th. I used:

    xcode 3.2.5
    ios 4.2
    sdk 3.0
     
  20. nikemerlino

    nikemerlino

    Joined:
    Jul 2, 2008
    Posts:
    66
    Not yet approved cause landscape mode.
    IPad needs both landscape right and landscape left, I changed plist with UIInterfaceOrientationIsLandscape.
    I put this code at startup without destroying it trough the scenes:

    Code (csharp):
    1. void Update () {
    2.        
    3.      DeviceOrientation currentOrientation = Input.deviceOrientation;
    4.  
    5.         switch (currentOrientation) {
    6.             case DeviceOrientation.LandscapeLeft:
    7.                 Screen.orientation = ScreenOrientation.LandscapeLeft;
    8.                 break;
    9.             case DeviceOrientation.LandscapeRight:
    10.                 Screen.orientation = ScreenOrientation.LandscapeRight;
    11.                 break;
    12.    
    13.         }
    14.        
    15.    
    16.     }
    Approved XCode 3.2.5 iOs 4.2 SDK iOs 4.2
    waiting for review......
     
  21. nikemerlino

    nikemerlino

    Joined:
    Jul 2, 2008
    Posts:
    66
    Approved!!
     
  22. iZero

    iZero

    Joined:
    Mar 31, 2011
    Posts:
    6
    hello together - I get the same problem - rejected -> cause -> crash (Xcode4) like the others here ... - I need to downgrade xcode now to :

    xcode 3.2.5
    ios 4.2
    sdk 3.0

    and then the app will be accepted ?
    will there come a Unity Update ?
     
  23. Dreamora

    Dreamora

    Joined:
    Apr 5, 2008
    Posts:
    26,603
    No it will not be accepted.
    You must use at very least 4.0 SDK, anything below 4.0 is not accepted at all anymore for appstore submission.

    You can use the 4.2 SDK or 4.3.x SDK with XCode 3.x (its a bit hidden below as a link itself).
     
  24. Mantas-Puida

    Mantas-Puida

    Unity Technologies

    Joined:
    Nov 13, 2008
    Posts:
    1,851
    That's not entirely correct SDK 4.3 + Xcode 3.x won't pass the review. You need SDK 4.2 (and Xcode that comes with it).

    We have submitted bug report to Apple and they assigned top priority for this issue, but currently there is no other known solution than downgrade you dev. environment to SDK 4.2.
     
  25. danielsonchris

    danielsonchris

    Joined:
    Feb 12, 2011
    Posts:
    43
    Looks like Apple has a new XCode release today of XCode 4.0.2 with iOS 4.3. Anyone have any input if the issues are still present?

    https://developer.apple.com/xcode/index.php

    Taken from 4.0.2 README:

    Whatʼs New in Xcode 4.0.2
    Fixed a bug with OpenGL apps running in the iOS Simulator on some Macs
    • Additional bug fixes and stability improvements
     
    Last edited: Apr 14, 2011
  26. WoodJazz

    WoodJazz

    Joined:
    Sep 15, 2010
    Posts:
    2
    Hi guys,
    Exactly same thing has happened to me.
    So far I was submitting to App Store with XCode 3.2.5 and iOS 4.2 without problems. Since I started to submit with XCode 4 my application has been rejected several times. (They say app crashes upon start). Everything works fine in my device but it looks like it does not work on Apple devices after submitting...
    I am wondering if this is an Apple or Unity problem ? Maybe there is a problem with the release process done in Apple...
    Also I have seen XCode 4.0.2 has been released. Is this new release going to solve this major issue?
     
  27. randyherring

    randyherring

    Joined:
    Feb 9, 2008
    Posts:
    42
    Same problem here. iPad 2 game rejected today. Unity 3.3 xcode 3.2.6 iOS 4.3. Cannot go to iOS 4.2 as this is an iPad 2 game.

    Hardware Model: iPad2,1
    Process: WizardCastle [781]
    Path: /var/mobile/Applications/2DAF3917-3EF0-4A47-8547-114A373F0534/WizardCastle.app/WizardCastle
    Identifier: WizardCastle
    Version: ??? (???)
    Code Type: ARM (Native)
    Parent Process: launchd [1]

    Date/Time: 2011-04-18 10:31:37.248 -0700
    OS Version: iPhone OS 4.3.2 (8H7)
    Report Version: 104

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0a50c584
    Crashed Thread: 0

    Thread 0 name: Dispatch queue: com.apple.main-thread
    Thread 0 Crashed:
    0 WizardCastle 0x007fab8c 0x1000 + 8362892
    1 WizardCastle 0x0071a7ec 0x1000 + 7444460
    2 WizardCastle 0x003ec794 0x1000 + 4110228
    3 WizardCastle 0x00004574 0x1000 + 13684
    4 WizardCastle 0x00003010 0x1000 + 8208

    Thread 0 crashed with ARM Thread State:
    r0: 0x82943161 r1: 0xd896214c r2: 0x82943161 r3: 0x00000000
    r4: 0x0098de90 r5: 0x000f8f23 r6: 0x00a1b5c0 r7: 0x2fdffa40
    r8: 0x007fa160 r9: 0x00000000 r10: 0x00000000 r11: 0x00000000
    ip: 0x00000000 sp: 0x2fdffa1c lr: 0xffffffff pc: 0x007fab8c
    cpsr: 0x80000010
     
  28. svenskefan

    svenskefan

    Joined:
    Nov 26, 2008
    Posts:
    282
    Hi!
    You should be able to compile it with 3.2 as deployment target, unless you absolutely need some 4+ features.
     
  29. randyherring

    randyherring

    Joined:
    Feb 9, 2008
    Posts:
    42
    It is an iPad 2 game which I am pretty sure requires iOS 4.3.
     
  30. kinzia

    kinzia

    Joined:
    Aug 14, 2010
    Posts:
    18
    my app also rejected by apple. the reason is "Your app crashed on both Wi-Fi and cellular networks on launch" and get "EXC_BAD_ACCESS(SIGBUS) in crash report.
    it is so strange that my app is never request internet and networks. is it a joke?
     
  31. Dreamora

    Dreamora

    Joined:
    Apr 5, 2008
    Posts:
    26,603
    ipad2 is iOS 4.3, right
    But that does not mean it can't run older games actually, if it did, apple would have had about 4M * XXXX complaints by now ;)
     
  32. Mantas-Puida

    Mantas-Puida

    Unity Technologies

    Joined:
    Nov 13, 2008
    Posts:
    1,851
    It's not in line with our experience, apps built with SDK 4.2 work just fine on iPad 2.
     
  33. Mantas-Puida

    Mantas-Puida

    Unity Technologies

    Joined:
    Nov 13, 2008
    Posts:
    1,851
    I guess, that's just standard wording.
     
  34. randyherring

    randyherring

    Joined:
    Feb 9, 2008
    Posts:
    42
    But can you specify iPad2 only features in iOS4.2? We marked our game to require the camera since it has to have iPad 2 to run, the iPad 1 does not have enough RAM.

    Thanks
    Randy
     
  35. Mantas-Puida

    Mantas-Puida

    Unity Technologies

    Joined:
    Nov 13, 2008
    Posts:
    1,851
    If you are using UIRequiredDeviceCapabilities in Info.plist then it should work the same under 4.2 SDK.
     
  36. randyherring

    randyherring

    Joined:
    Feb 9, 2008
    Posts:
    42
    I can't get 4.2 to work for me. So I guess I need the fix for 4.3 as soon as it is available.
    Thanks
    Randy
     
  37. Mantas-Puida

    Mantas-Puida

    Unity Technologies

    Joined:
    Nov 13, 2008
    Posts:
    1,851
    Could you please give more details on what prevents 4.2 from working for you?
     
  38. Phil W

    Phil W

    Joined:
    Dec 21, 2008
    Posts:
    231
    No problems here building to iPad 2 (iOS SDK 4.3, XCode 3.2.6)

    We have had some disparity with shaders - specular effects corrupting on iPad 2 but not iPad 1, to be reported once we're certain we can't figure out why.
     
    Last edited: Apr 21, 2011
  39. randyherring

    randyherring

    Joined:
    Feb 9, 2008
    Posts:
    42
    It was not a Unity issue. Since I am in development on an iPhone version of the game on my main Dev machine, I did not want to uninstall Xcode and downgrade. So I tried updating an older version of Xcode on an old Mac and ran into issue with certificates. Since this is not my day job, I decided to spend my limited time on the iPhone development and wait for the Unity iOS 4.3 fix instead of fighting with the Xocde install on the old Mac.

    Any news on when the issue may be resolved?
    Thanks
    Randy
     
  40. mindlube

    mindlube

    Joined:
    Oct 3, 2008
    Posts:
    993
    Can someone summarize what the state of this is issue? I saw the post by mantasp that says to use SDK 4.2. Does that mean I need to download and install the 4.2 SDK instead of 4.3? Or in unity build settings, select SDK Version, select 4.2 instead of iOS latest?
    If the former, can someone give the URL to download it? It's not easy to find old SDKs on apple's site.
     
    Last edited: Apr 22, 2011
  41. danielsonchris

    danielsonchris

    Joined:
    Feb 12, 2011
    Posts:
    43
    @mindlube No idea regarding how far along the Unity staff are with making this fix. I'm holding out for it as well. Would be nice to have a fix for this soon. Use iOS 4.2 SDK and see the bottom of page 3 of this forum thread for a download link.
     
  42. Ferazel

    Ferazel

    Joined:
    Apr 18, 2010
    Posts:
    355
    Just wanted to say that we submitted our app with the Unity 3.3 with XCode 4.01 and SDK 4.3 and the problem remains as we received a VERY similar app rejection from Apple. The app runs fine on our devices with the same devices that Apple was testing. We are downgrading our XCode to 3.25 with the 4.2 SDK and trying to submit the app again today and will let you know the results to see if we have any luck doing that.

    However, I just wanted to say that the problem still persists, and I wish that Unity would at least put this as a sticky, or put it on the support page noting this problem instead of relying on people to submit an app that is going to be rejected and searching the forums afterwards for this thread. >:|
     
  43. mindlube

    mindlube

    Joined:
    Oct 3, 2008
    Posts:
    993
    @danielsonchris, thanks for summarizing. I could not find the download link in this thread. However it's accessible this way:
    go to connect.apple.com, sign in > downloads > developer tools > search the page for SDK 4.2
     
  44. danielsonchris

    danielsonchris

    Joined:
    Feb 12, 2011
    Posts:
    43
    Last edited: Apr 22, 2011
  45. randyherring

    randyherring

    Joined:
    Feb 9, 2008
    Posts:
    42
    Any news on when we can expect a fix for this issue? Is it a Unity problem or an Apple problem?
    Thanks,
    Randy
     
  46. mst3king

    mst3king

    Joined:
    Apr 25, 2011
    Posts:
    1
    I would also like to see a fix to this problem. I had my app rejected for the same reason as others in this thread (rejected because of crashing). I submitted a paid version of my game about a month ago using the 4.2 SDK and it was approved on the first shot. I recently tried to submit a free version of the exact same game plus iAds (using the 4.3 SDK and xcode 3.2.6) and it got rejected. I tested it thoroughly and never came across any crashing problems. The reason I can't downgrade to the 4.2 SDK is because I recently bought the prime 31 iAd plugin for Unity. I was not able to get the iAd plugin working when I was using the 4.2 SDK. I had to upgrade to the 4.3 SDK in order to get the iAd plugin to work. So basically, I can submit my game if I went back to 4.2 SDK but I won't be able to submit it with ads using the iAd plugin (which is the whole reason I bought the plugin in the first place). I realize it's not Unity's responsibility to cover 3rd party plugins but still this is an issue that should be resolved.
     
  47. prime31

    prime31

    Joined:
    Oct 9, 2008
    Posts:
    6,427
    @mst3king, just comment out/delete the plugin methods that have to do with interstitials. Interstitials are the only reason that iOS 4.3 is required.
     
  48. btiger19

    btiger19

    Joined:
    Jun 28, 2009
    Posts:
    56
    Got the same problem on iPhone4 iOS 4.3.2 + xcode 4.0.
    Does the latest xcode 4.0.2 fix this problem?
     
  49. exia

    exia

    Joined:
    Sep 7, 2009
    Posts:
    7
    help!! my app too:
    We found that your app crashed on iPad2 running iOS 4.3.2, which is not in compliance with the App Store Review Guidelines.

    Your app crashed again on both Wi-Fi and cellular networks upon launch.
     
  50. rombowich

    rombowich

    Joined:
    Apr 26, 2009
    Posts:
    55
    Me,too.
    what should I do :-(