Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

Question "Invalid configuration request for gameId: [correct ID?]"

Discussion in 'Unity Ads & User Acquisition' started by PatAndStormy, May 24, 2022.

  1. PatAndStormy

    PatAndStormy

    Joined:
    Jun 11, 2017
    Posts:
    5
    Hello! I'm using Unity Ad services, and after opening unity today this error popped up:

    Code (CSharp):
    1. Invalid configuration request for gameId: [id number here]
    2. System.Threading._ThreadPoolWaitCallback:PerformWaitCallback ()
    3.  
    4. The remote server returned an error: (404) Not Found.
    5. System.Threading._ThreadPoolWaitCallback:PerformWaitCallback ()
    6.  
    Everything was working at the time I last had unity opened, so I am not sure what could have happened. The IDs are correct according to the dashboard. My code is basically copied and pasted from the example docs and the issue happens at initialization ofc. Is there anything I should check that I might be missing?

    I saw there was a post previously about this issue/similar, but that appeared to have been resolved and I am guessing I messed something up.
     
  2. dwilden

    dwilden

    Joined:
    Mar 29, 2021
    Posts:
    20
    I have same issue when running a project that previously showed the test interstitial ad when running from the editor. It now fails to initialise the ads with the same 2 errors that you have posted.

    When I build and run the project and run it on an actual android device it builds and runs fine and shows real ads fine. So this shows there is no problem with the gameid (which I have checked is still the correct one for my project anyway).

    Suggests to me it's a Unity server issue with whatever services the test mode ad page?
     
    PatAndStormy likes this.
  3. PeachyPixels

    PeachyPixels

    Joined:
    Feb 17, 2018
    Posts:
    716
    Last edited: May 24, 2022
    FamishedMammal likes this.
  4. Jimb4ik

    Jimb4ik

    Joined:
    Jun 3, 2018
    Posts:
    8
    I have same issue from today
     
  5. drumrdrumr

    drumrdrumr

    Joined:
    Dec 28, 2021
    Posts:
    1
    I am getting the same message today as well. So it's not just me...
     
  6. dwilden

    dwilden

    Joined:
    Mar 29, 2021
    Posts:
    20
    I found a fix that was posted in another thread and it worked for me today. I've pasted it verbatim below.

    "Hi there, I was also getting the same error: " Remote Server returned an error: (404) Not Found" (Unity 2021.3). I turned OFF-ON the button (Monetize your games) located in Project Settings > Services > Ads and the error was fixed. Maybe this can help someone."
     
    PatAndStormy likes this.
  7. PatAndStormy

    PatAndStormy

    Joined:
    Jun 11, 2017
    Posts:
    5
    That's good to know, a few failed test ads in the editor isn't nearly as a big deal as lost revenue (well, for those of you who make any money to begin with lol).

    Kind of frustrating still since its clearly an issue a lot of us are having but service statuses are all "operational" :rolleyes:. The ol' off-and-on as suggested below and in the other thread worked for me but whether that's really a permanent solution I do not know. Why that works is also a mystery to me given nothing facially changes.
     
  8. Jimb4ik

    Jimb4ik

    Joined:
    Jun 3, 2018
    Posts:
    8
    My ON/OFF button is not clickable anymore. Any thought how to fix it?
     
    FamishedMammal likes this.
  9. FamishedMammal

    FamishedMammal

    Joined:
    Nov 3, 2015
    Posts:
    120
    Same issue!
     
  10. SamOYUnity3D

    SamOYUnity3D

    Unity Technologies

    Joined:
    May 12, 2019
    Posts:
    626
    This problem has been fixed, please try again. Sorry for the inconvenience caused.
     
    PatAndStormy and PeachyPixels like this.
  11. FamishedMammal

    FamishedMammal

    Joined:
    Nov 3, 2015
    Posts:
    120
    Hi Sam, this is not fixed for me. I am using editor 2019.4.39f1
    I've tried both methods: importing through the package manager, and enabling in Services window. Neither works (UnityAds is never initialized upon calling Advertisement.Initialize either). I've used Unity Ads over 10 times in various projects, and never had problems with past implementations. This is a new issue.
     
    Last edited: May 26, 2022
  12. SamOYUnity3D

    SamOYUnity3D

    Unity Technologies

    Joined:
    May 12, 2019
    Posts:
    626
    Let's talk about this in another thread: https://forum.unity.com/threads/adv...s-not-clickable-anymore.1286792/#post-8160875