Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Question Instantiating GameObject with TextMeshPro showing in SceneView but not GameView

Discussion in 'UGUI & TextMesh Pro' started by NotMyUsernameAgain, Mar 29, 2024.

  1. NotMyUsernameAgain

    NotMyUsernameAgain

    Joined:
    Sep 28, 2017
    Posts:
    142
    Hi everyone,
    as the title says.

    I instantiated muliple GameObjects with one child that holds the TextMeshPro component (not UGUI).

    Visible in Editor but not in GameView.

    Already tried using other MaterialPresets (no effect) and other fonts.
    But if I try to change the font ot the instantiated objects, the text become colored blocks (only in GameView), though changing font of not instantiated text works normally.
    Only the standard font "LiberationSans SDF" shows nothing, all other fonts I tried show colored blocks in GameView.
     
    Last edited: Mar 29, 2024