Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. The 2023.1 beta is now available for testing. To find out what's new, have a look at our 2023.1 feature highlights.
    Dismiss Notice

Instant crash on standalone if Entities package installed (2019.2.0a11-a14)

Discussion in '2019.2 Beta' started by rz_0lento, May 3, 2019.

  1. rz_0lento

    rz_0lento

    Joined:
    Oct 8, 2013
    Posts:
    2,357
    Pretty much what topic said. If you have any project with Entities package (even with only empty scene) and use 2019.2.0a11, a13 or a14, standalone build will instantly crash when you try to run it.

    2019.1.0f2 and 2019.2.0a9 work fine on standalone with ECS. Entities package version doesn't seem to matter, I tried bunch between preview.26 and latest preview.31 and they all crashed on newer alphas.

    Posting here for awareness. Issue ID #1151396
     
  2. Shinyclef

    Shinyclef

    Joined:
    Nov 20, 2013
    Posts:
    468
    Oh I wonder if this is why my standalone player crashed!
    I did discover though that in my case, choosing the 'development build' option in the build setting prevented the crash.
     
  3. rz_0lento

    rz_0lento

    Joined:
    Oct 8, 2013
    Posts:
    2,357
    We discussed this on official Unity Discord and yes, development build seems to work even on a14. This can be used as a workaround for the time being, altho it's not a real solution. :)
     
  4. rz_0lento

    rz_0lento

    Joined:
    Oct 8, 2013
    Posts:
    2,357
    I got response from the support. This is a known issue and already fixed on 2019.3 alpha (which is not available atm).
     
  5. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    3,045
    This will also be fixed in the next 2019.2 release.
     
    T-Zee, FROS7 and rz_0lento like this.