Search Unity

Installing Unity on macOS Catalina

Discussion in 'OSX' started by nickrapp, Jun 3, 2019.

  1. nickrapp

    nickrapp

    Unity Technologies

    Joined:
    Oct 5, 2015
    Posts:
    47
    Hey macOS Unity users, if you're running into issues with the Unity Installer while trying out the version of macOS that Apple announced at WWDC today, you can fix the error by updating your version of Unity with the instructions below:

    All versions of Unity available via the Unity Hub can be installed without issue. If you need the Download Assistant for offline installation, you can update via fixed versions of the installers. An updated 2017 installer can be found here, and an updated 2018 installer will be available later this week with the release of 2018.4.2. Previous versions of the installer will not be compatible with macOS Catalina.


    We're working to resolve the error and we’ll let you know here when everything is updated. Let us know if you’re having any issues in the meantime.
     
    momoandbanana, QFord and JoeStrout like this.
  2. Colin_MacLeod

    Colin_MacLeod

    Joined:
    Feb 11, 2014
    Posts:
    114
    Hey, not sure this is the right place to post, but I'm experiencing issues starting one of our games in Unity on Catalina.

    It is running on Unity 2018.2.21f1 and always gets stuck on startup when importing the wav files. The same project seems fine on Mojave.

    Other titles on 2018.3.x and 2019.1.x seem to be unaffected. Is this a known issue? Any ideas how I can workaround?
     
    Grant-Christie and GlynWilliams like this.
  3. JanetRGilbert

    JanetRGilbert

    Joined:
    Sep 25, 2017
    Posts:
    5
    I'm running the beta version of Catalina and using an old version of Unity 5.6.4f1 and I get the same problem importing wav files.
     
  4. JanetRGilbert

    JanetRGilbert

    Joined:
    Sep 25, 2017
    Posts:
    5
    I also can't import shaders, due to UnityShaderCompiler being 32-bit only. Seems like Unity 5 is basically incompatible with Catalina. Can we expect a fix @nickrapp or is Unity 5 going to become unsupported?
     
  5. andrews_unity

    andrews_unity

    Unity Technologies

    Joined:
    Dec 11, 2015
    Posts:
    39
    @JanetRGilbert Unity 5 will not be getting any backport or fixes for MacOS 10.15, as for the Wav Importer issue we are looking into this issue.
     
    JanetRGilbert likes this.
  6. andrews_unity

    andrews_unity

    Unity Technologies

    Joined:
    Dec 11, 2015
    Posts:
    39
    Update:

    The Wav file import issue with 2017.4 LTS, we have identified the issue as being an issue with an FMOD Tool being 32bit which is not supported in MacOS 10.15. We will release a fix for 2017.4 LTS but we will not be releasing an update for 2018.1/2018.2 as these are unsupported releases. The issue doesn't manifest in 2018.3+ and we will update the documentations etc.. to represent the support matrix below.

    MacOS 10.15 Support:

    2017.4 LTS
    2018.3/LTS
    2019.1+
     
    Colin_MacLeod and nukatomic like this.
  7. adamgryu

    adamgryu

    Joined:
    Mar 1, 2014
    Posts:
    71
    Hi! Is this fixed yet?

    I'm on 2018.4.2f1 and I'm wondering if upgrading will fix the issue for a Mac user of mine.
     
  8. aresundnes

    aresundnes

    Joined:
    Apr 29, 2013
    Posts:
    3
    I have upgraded to Catalina because I need to build for the upcoming iOS13 and Catalina.
    I also have audio import problems - not only WAV but also OGG. We do not use FMOD. The editor crashes with the following message every time:

    Code (csharp):
    1.  
    2. Updating Assets/Audio/audiofile.ogg - GUID: 00220d8f589904b9c9b5b706a127b140...
    3. 2019-08-02 13:46:51.735 Unity[8933:146743] *** -[NSConcreteTask terminationStatus]: task not launched
    4.  
    I have upgraded the the latest LTS 2017.430f1.
    Any ETA for fixing this? Or workaround? @andrews_unity
     
    Last edited: Aug 2, 2019
    momoandbanana likes this.
  9. aresundnes

    aresundnes

    Joined:
    Apr 29, 2013
    Posts:
    3
    Managed to get a better stack trace of the exception


    2019-08-02 14:51:09.664 Unity[5898:55910] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[NSConcreteTask terminationStatus]: task not launched'
    *** First throw call stack:
    (
    0 CoreFoundation 0x00007fff37fb4183 __exceptionPreprocess + 250
    1 libobjc.A.dylib 0x00007fff6e4beb64 objc_exception_throw + 48
    2 Foundation 0x00007fff3a65fdbb -[NSConcreteTask terminationStatus] + 175
    3 Unity 0x00000001006bdecc _Z16LaunchExecutableRKN4core12basic_stringIcNS_20StringStorageDefaultIcEEEERKSt6vectorIS3_SaIS3_EES5_PS3_PjSB_ + 2924
    4 Unity 0x000000010146ed58 _ZN13AudioImporter18AttemptTranscodingERKN4core12basic_stringIcNS0_20StringStorageDefaultIcEEEES6_RKNS_14SampleSettingsEN10SampleClip15ContainerFormatEbbPS4_ + 4552
    5 Unity 0x000000010146bff2 _ZN13AudioImporter17GenerateAssetDataEv + 1362
    6 Unity 0x0000000102473aaf _ZN15AssetDatabaseV111ImportAssetE9UnityGUIDR5AssetRKN4core12basic_stringIcNS3_20StringStorageDefaultIcEEEES9_R22AssetImporterSelectionN13AssetDatabase18UpdateAssetOptionsERKNS3_17string_with_labelILi1EEEbR31InstanceIDLocalIdentifierLookupR13dynamic_arrayIP6ObjectLm8EE + 1183
    7 Unity 0x0000000102478c36 _ZN15AssetDatabaseV111UpdateAssetERK9UnityGUIDS2_N13AssetDatabase18UpdateAssetOptionsE7Hash128P24AssetImportingTimerStats + 4438
    8 Unity 0x00000001024b407f _ZN14AssetInterface27ProcessAssetsImplementationERd15CancelBehaviourN13AssetDatabase18UpdateAssetOptionsE + 1087
    9 Unity 0x00000001024b3691 _ZN14AssetInterface16StopAssetEditingE15CancelBehaviourN13AssetDatabase18UpdateAssetOptionsE + 465
    10 Unity 0x00000001024b8191 _ZN14AssetInterface7RefreshEN13AssetDatabase18UpdateAssetOptionsE + 11521
    11 ??? 0x00000001246f3352 0x0 + 4906234706
    12 ??? 0x00000001246f3286 0x0 + 4906234502
    13 ??? 0x0000000148de8a5f 0x0 + 5517511263
    14 ??? 0x0000000148de2a20 0x0 + 5517486624
    15 ??? 0x0000000148de2861 0x0 + 5517486177
    16 ??? 0x0000000148de256a 0x0 + 5517485418
    17 ??? 0x0000000148ddbecd 0x0 + 5517459149
    18 ??? 0x0000000122717916 0x0 + 4872829206
    19 libmono.0.dylib 0x000000013acc13a2 mono_get_runtime_build_info + 3654
    20 libmono.0.dylib 0x000000013adedb92 mono_runtime_invoke + 117
    21 libmono.0.dylib 0x000000013adee059 mono_runtime_class_init_full + 1025
    22 libmono.0.dylib 0x000000013adedc53 mono_runtime_class_init + 18
    23 libmono.0.dylib 0x000000013adb35d5 mono_register_jit_icall + 42299
    24 ??? 0x00000001488b394b 0x0 + 5512051019
    25 ??? 0x00000001488b3884 0x0 + 5512050820
    26 ??? 0x00000001488b358e 0x0 + 5512050062
    27 ??? 0x00000001488b1c33 0x0 + 5512043571
    28 ??? 0x00000001488b22b6 0x0 + 5512045238
    29 libmono.0.dylib 0x000000013acc13a2 mono_get_runtime_build_info + 3654
    30 libmono.0.dylib 0x000000013adedb92 mono_runtime_invoke + 117
    31 Unity 0x000000010101980a _ZN19ScriptingInvocation6InvokeEP21ScriptingExceptionPtrb + 106
    32 Unity 0x0000000100fde028 _ZN11MonoManager27SetupLoadedEditorAssembliesEv + 984
    33 Unity 0x0000000100fdfa6a _ZN11MonoManager17EndReloadAssemblyERK19DomainReloadingData14dynamic_bitset + 1914
    34 Unity 0x0000000100fde67f _ZN11MonoManager14ReloadAssemblyEb + 367
    35 Unity 0x000000010131512e _ZL27LoadDomainAndUserAssembliesv + 174
    36 Unity 0x000000010131446b _Z41LoadMonoAssembliesAndRecompileIfNecessaryb + 3259
    37 Unity 0x00000001019ae451 _ZN11Application17InitializeProjectEv + 8225
    38 Unity 0x00000001006b71a9 -[EditorApplication applicationDidFinishLaunching:] + 249
    39 CoreFoundation 0x00007fff37f6533c __CFNOTIFICATIONCENTER_IS_CALLING_OUT_TO_AN_OBSERVER__ + 12
    40 CoreFoundation 0x00007fff37ff5b40 ___CFXRegistrationPost1_block_invoke + 63
    41 CoreFoundation 0x00007fff37ff515b _CFXRegistrationPost1 + 372
    42 CoreFoundation 0x00007fff37f6d82e ___CFXNotificationPost_block_invoke + 97
    43 CoreFoundation 0x00007fff37ed62e2 -[_CFXNotificationRegistrar find:eek:bject:eek:bserver:enumerator:] + 1575
    44 CoreFoundation 0x00007fff37ed5772 _CFXNotificationPost + 1351
    45 Foundation 0x00007fff3a60daab -[NSNotificationCenter postNotificationName:eek:bject:userInfo:] + 59
    46 AppKit 0x00007fff3516a0a3 -[NSApplication _postDidFinishNotification] + 312
    47 AppKit 0x00007fff35169da6 -[NSApplication _sendFinishLaunchingNotification] + 208
    48 AppKit 0x00007fff3516800b -[NSApplication(NSAppleEventHandling) _handleAEOpenEvent:] + 549
    49 AppKit 0x00007fff35167c5e -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 688
    50 Foundation 0x00007fff3a6568cf -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 308
    51 Foundation 0x00007fff3a656739 _NSAppleEventManagerGenericHandler + 98
    52 AE 0x00007fff3933f43a aeProcessAppleEvent + 3021
    53 AE 0x00007fff3933eb60 aeProcessAppleEvent + 755
    54 AE 0x00007fff3933ea2e aeProcessAppleEvent + 449
    55 HIToolbox 0x00007fff36ab8808 AEProcessAppleEvent + 54
    56 AppKit 0x00007fff35164294 _DPSNextEvent + 1670
    57 AppKit 0x00007fff35162d5c -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1352
    58 AppKit 0x00007fff3515d4f6 -[NSApplication run] + 658
    59 AppKit 0x00007fff3514f3de NSApplicationMain + 777
    60 Unity 0x00000001006d6187 _Z10EditorMainiPPKc + 839
    61 Unity 0x00000001006d6609 main + 9
    62 libdyld.dylib 0x00007fff6f8142f5 start + 1
    )
    libc++abi.dylib: terminating with uncaught exception of type NSException
     
  10. andrews_unity

    andrews_unity

    Unity Technologies

    Joined:
    Dec 11, 2015
    Posts:
    39
    Just to note here 2018.4 LTS and 2019+ doesn't have this issue, as for when 2017.4 it should be resolved in the next update.
     
    nukatomic and JoeStrout like this.
  11. nukatomic

    nukatomic

    Joined:
    Jun 26, 2019
    Posts:
    2
    LTS Release 2017.4.31f1 is out.
    The problem with Mac OS Catalina 10.15 importing MP3/ WAV is still here.
     
  12. andrews_unity

    andrews_unity

    Unity Technologies

    Joined:
    Dec 11, 2015
    Posts:
    39
    Going to be the next release :D of 2017.4 that is
     
    nukatomic likes this.
  13. nukatomic

    nukatomic

    Joined:
    Jun 26, 2019
    Posts:
    2
    Sounds good! Thank you.
     
  14. anhtuanpro95hy

    anhtuanpro95hy

    Joined:
    Jun 6, 2017
    Posts:
    1
    UnitySetup-Android-Support-for-editor-2018.4.7f1 pkg
    cannot install in MacOS catalina.
    Please help me :((
     
  15. unity_u8we9PXZAPf8Rw

    unity_u8we9PXZAPf8Rw

    Joined:
    Aug 20, 2019
    Posts:
    1
    Any luck? I'm able to on my personal machine, but not my corporate machine...which is the one I need it on :) Same behavior behind the firewall, on VPN or just on my home network.

    I don't see anything too weird in the diagnostic report other than "Wakeups: 45001 wakeups over the last 69 seconds (655 wakeups per second average), exceeding limit of 150 wakeups per second over 300 seconds". I've attached the diagnostic report just in case anyone else can see anything useful in it :).a

    For what it's worth, people with the same computer, on High Sierra have no issues.

    When I try to download the installer instead of the hub, I get a different error, but the same log. It claims the drive I'm installing to can't be written to. That's a lie.

    Thanks in advance for any help you can provide.
     

    Attached Files:

  16. badradionz

    badradionz

    Joined:
    Feb 2, 2018
    Posts:
    21
    This is extremely frustrating, just started happening on catalina.
     

    Attached Files:

  17. PixelJ

    PixelJ

    Unity Technologies

    Joined:
    Nov 1, 2018
    Posts:
    143
  18. andrews_unity

    andrews_unity

    Unity Technologies

    Joined:
    Dec 11, 2015
    Posts:
    39
    @badradionz I think your issue has been resolved

    https://issuetracker.unity3d.com/is...122.38132525.1567718971-1329340620.1539040924

    This would cause a bunch of errors when you try and reopen the project :( which version were you using as this was fixed in 2018.4.8+

    As for the installer issue I was able to install android support via the latest version of the Unity Hub (2.2.1) on 2018.4.8 on the current public beta of Catalina with no issue. I also verified that if you use the UnityInstaller directly the installation works fine, but the pkg files do seem to run into the read only issue mentioned above. We shall look further into that.
     
  19. IndieFist

    IndieFist

    Joined:
    Jul 18, 2013
    Posts:
    349
    Same problem here. Cannot install any version of unity in Catalina OS. "Unity can't be installed on this disk. The contents of this disk can't be changed"
    Feels like Unity have to ask In a new way permission to install and those guys haven't tested right now.
     
  20. AntWorkshop

    AntWorkshop

    Joined:
    May 23, 2018
    Posts:
    1
    Same - I'm trying to install Unity 2019.2.5 on Catalina but Hub doesn't have that version (not sure why?) and the installer on the download archive doesn't work in OSX10.15, despite being from September, well after this post.
     
    IndieFist likes this.
  21. IndieFist

    IndieFist

    Joined:
    Jul 18, 2013
    Posts:
    349
    I have found a solution, you can download any version from website and before to install select install this version with Unity Hub, it works!
     
  22. IndieFist

    IndieFist

    Joined:
    Jul 18, 2013
    Posts:
    349
    I have just send a bug report. Any time I do a build in catalina os I have break all shaders and get a black screen or pink textures.
    Same project, same unity version but Mojave the build works without problems
     
    kangchihkuo, firehot and Milkycool like this.
  23. andrews_unity

    andrews_unity

    Unity Technologies

    Joined:
    Dec 11, 2015
    Posts:
    39
    So here again I have verified today that with the latest version of the hub I was able to install 2018.4/2017.4 and the latest version of 2019.3 without issue.

    When you are saying that you are running into issue is this with the pkg files or the hub as well ?
     
    IndieFist likes this.
  24. IndieFist

    IndieFist

    Joined:
    Jul 18, 2013
    Posts:
    349
    I just have been downgrade again my system back to Mojave Os, downloaded same version of unity, same project and I have do a build and no problem.

    This is the thread with the errors I can see while do a debug in terminal:
    https://forum.unity.com/threads/err...th-shader-guitextureclip.755054/#post-5028269

    This could be related with anything about Catalina OS does not support 32 bits and shader compiler?
     
  25. andrews_unity

    andrews_unity

    Unity Technologies

    Joined:
    Dec 11, 2015
    Posts:
    39
    @IndieFist The shader compiler is 64bit so that should not be an issue, do you have the full logs, and also can you file a bug with a small repro and if possible can you try building against 2019.3
     
    IndieFist likes this.
  26. IndieFist

    IndieFist

    Joined:
    Jul 18, 2013
    Posts:
    349
    Right now Im in Mojave again because I need to send an update and can work with Catalina, but I will try it again next week.
     
    firehot likes this.
  27. PixelEnvision

    PixelEnvision

    Joined:
    Feb 7, 2012
    Posts:
    486
    Shader complier is running but not just properly. I've submitted a bug report with a repo yesterday which is as minimal as it can get, just a blank new project only with TextMesh Pro essential resources package imported.
    Issue ID: 1190831

    Also, Unity 2019.3.0b6 is working correctly with the same setup & project.

    So, I've tried replacing UnityShaderCompiler with the one from b6 and guess what, everything seems to be working now. Tested this with 2019.2.8f1 & 2019.2.9f1
     
    IndieFist likes this.
  28. IndieFist

    IndieFist

    Joined:
    Jul 18, 2013
    Posts:
    349
    Hi! I just have updated too and works fine, there is no problem with Unity 2019.3
    Best regards.
     
  29. KB73

    KB73

    Joined:
    Feb 7, 2013
    Posts:
    197
    Go

    Going to try 2019.3 shortly

    2019.2.9 on catalina on android is giving us pink shaders for debug shaders etc
    Tried replacing the shader compiler with no luck ( it removed errors but shaders are still pink )

    * The shader compiler workaround actually worked, the issue was we were transitioning from the older assetbundle system to addressables and we had to do it in stages - having 1 bundle with old assets hanging around 'confused' the system = shaders pink...once we cleared that out, we were fine.

    It would be nice to get a fix for 2019.2.X for the shader compiler stuff tho....otherwise we're going to see how 2019.3f1 plays out when it comes out..in ...2019? :D
     
    Last edited: Oct 29, 2019
  30. SixTimesNothing

    SixTimesNothing

    Joined:
    Dec 26, 2007
    Posts:
    161
    For those stuck on the audio import problem in Catalina on older and unsupported versions of Unity, I was able to fix this myself by replacing the (presumably 32 bit) FSBTool executable in the older Unity version with the new (64 bit) FSBTool taken from the latest Unity version.

    Audio import now works fine and as expected so far... though please note that this is a hacky solution, hopefully it won't have other side effects, but I can't say for sure! I have saved the older FSBTool file as a backup just in case.

    This is the file I replaced:
    <Version>/Unity.app/Contents/Tools/FSBTool
    (Right click and select Show Package Contents to access the content of Unity.app)
     
    artboard, Kardinal and Reisender like this.
  31. teddybear124popov

    teddybear124popov

    Joined:
    Oct 28, 2019
    Posts:
    2
    unity hub latest version does not work at all in Catalina beta.
     
  32. teddybear124popov

    teddybear124popov

    Joined:
    Oct 28, 2019
    Posts:
    2
    I tried and try to install the unity hub on Catalina beta. but it does not work at all.
     
  33. KB73

    KB73

    Joined:
    Feb 7, 2013
    Posts:
    197
    We're running it fine on catalina official release, we're not using the beta
     
  34. Artpen

    Artpen

    Joined:
    Jan 24, 2015
    Posts:
    50
    Any plans to fix shaders compiling problem on Catalina Unity 2019.2.10 ?
    Also if I try to change to Linear colour space Unity Editor goes PINK !

    I am still getting this:

     
    vfilho likes this.
  35. Artpen

    Artpen

    Joined:
    Jan 24, 2015
    Posts:
    50
    Jus to confirm, same project in 2019.3.0b work fine and I am able to build it. Please fix 2019.2.XX
     
  36. KB73

    KB73

    Joined:
    Feb 7, 2013
    Posts:
    197
    The only workaround is to copy the shadercompiler from the Unity.app Tools in 2019.3b8 over the one in the 2019.2.10 - that is the only soln that worked for us..
     
    Last edited: Oct 29, 2019
  37. hongjianxi

    hongjianxi

    Joined:
    Apr 10, 2019
    Posts:
    1
    Unable to install 2018.1.9f2 on Catalina, neither via install-assistant nor Unity-Hub. It saids, Unity can't be installed on this disk, the contents of this disk can't be changed.
    upload_2019-10-30_17-53-51.png
     
  38. Reisender

    Reisender

    Joined:
    Jun 26, 2014
    Posts:
    28
    My hero! That worked!
     
  39. mmvlad

    mmvlad

    Joined:
    Dec 31, 2014
    Posts:
    86
    I had the same issue. Has to download the install package via torrent. It installed fine.
    Though lots of errors on Catalina 20.15.1 and Unity 2019.2.9 (shader compilation errors etc)
     
  40. vfilho

    vfilho

    Joined:
    Jun 25, 2016
    Posts:
    20
    This is a mess, even when I tried the beta on importing process the Unity is crashing, I will have to tray downgrade the mac os.

    I started facing errors with shaders.
     
  41. vfilho

    vfilho

    Joined:
    Jun 25, 2016
    Posts:
    20
    Trying that workaround...
     
  42. vfilho

    vfilho

    Joined:
    Jun 25, 2016
    Posts:
    20
    Thanks Man that worked for me!
     
    KB73 likes this.
  43. artboard

    artboard

    Joined:
    Nov 14, 2019
    Posts:
    1
    Worked like a charm! Thank you for saving my time ;)
     
  44. ObsessiveGames

    ObsessiveGames

    Joined:
    Nov 18, 2019
    Posts:
    1

    When I attempt to install Unity Hub or manually download and install Unity 2019, Mac Installer throws this error message:
    “Unity.pkg” can’t be opened because Apple cannot check it for malicious software.

    Is Unity working to resolve this?
     
  45. glad

    glad

    Joined:
    May 10, 2014
    Posts:
    70
    Could you please tell what 'shadercompiler' is ? I can't find any folder like that.

    My case:
    I use Catalina. I've installed 2019.2.11 and faced the same problem with shaders. I decided to use your suggestion, but can't understand what is 'shadercompiler'. I installed the 2019.3.0b11 and tried to find something there. But didn't find anything. Could you please explain what to do in details?

    Thank you in advance!
     
  46. KB73

    KB73

    Joined:
    Feb 7, 2013
    Posts:
    197
    \

    Open up the Unity.app package ( right click show contents, go to the tools folder and find the shader compiler, copy that over the same place in the other version of Unity )

    Hope that helps
     
  47. glad

    glad

    Joined:
    May 10, 2014
    Posts:
    70
    Thank you!
    However that not helped. I've found UnityShaderCompiler file in 2019.3.0b11 and copied it to 2019.2.11

    Still having issues like:
    WARNING: Shader Unsupported: 'Hidden/Internal-MotionVectors' - Pass '' has no vertex shader
    WARNING: Shader Unsupported: 'Hidden/Internal-MotionVectors' - Pass '' has no fragment shader
    WARNING: Shader Unsupported: 'Hidden/Internal-MotionVectors' - Setting to default shader.
    WARNING: Shader Unsupported: 'Hidden/Internal-GUITexture' - Pass '' has no vertex shader
    2019-11-22 11:49:27.104682+0300 Compiler failed to build request
    Metal: Error creating pipeline state (Hidden/Internal-GUITexture): Fragment input(s) `user(TEXCOORD0)` mismatching vertex shader output type(s) or not written by vertex shader

    ...
    WARNING: Shader Unsupported: 'Legacy Shaders/VertexLit' - Pass '' has no vertex shader

    ERROR: Shader Shader is not supported on this GPU (none of subshaders/fallbacks are suitable)WARNING: Shader Unsupported: 'Legacy Shaders/VertexLit' - Setting to default shader.

    WARNING: Shader Unsupported: 'Custom/Fluids' - Pass '' has no fragment shader

    ERROR: Shader Shader is not supported on this GPU (none of subshaders/fallbacks are suitable)WARNING: Shader Unsupported: 'Custom/Fluids' - Setting to default shader.

    Failed to find expected binary shader data in 'Standard'.

    and so on..




     
  48. glad

    glad

    Joined:
    May 10, 2014
    Posts:
    70
    @nickrapp Hope you guys fix that, because this is not good. I can't do build for iOS on Catalina
     
  49. Harrishun

    Harrishun

    Joined:
    Apr 13, 2016
    Posts:
    11
    Hi @IndieFist, are you able to give me a bit more information on this? I am trying to install 2019.1.11f1 on a used Macbook Pro (mid-2015, reset to factory default, Catalina installed) and cannot see this option.
     
    IndieFist likes this.
  50. glad

    glad

    Joined:
    May 10, 2014
    Posts:
    70
    By the way, I've found such thing: if I try to install unity version with Android/iOS marks checked, but without NDK(for android) checked, this version would not be installed. However if you check NDK to install the version would be installed normally