Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Bug Input System - Android Build Black Screen with no Unity Logo

Discussion in 'Input System' started by dARkStorN-, Aug 19, 2020.

  1. dARkStorN-


    Dec 21, 2018
    Hello dear Unity Devs,

    Yesterday i opened up a new project (2019.4.8, URP) and worked on a simple touch controller with the new input system package. I built the project on an android device (Galaxy S7 Edge) and opened the application but there was only black screen and even the unity logo didn't show up.
    I tried to replicate this problem by opening up a new project and adding a input system package again. First, i get a build without creating an input action asset after installing the input system package and it worked. My empty scene with simple cube was loaded. However, after i create an input action asset and use tap and hold touchscreen interactions, which was working in editor with simulated touch, my build on android device gave me black screen problem again with no unity logo whatsoever.

    If anyone faced the same issue and worked out a solution, it would be very helpful.

  2. Rene-Damm


    Unity Technologies

    Sep 15, 2012
    Hi @dARkStorN-, would you mind filing a ticket with the Unity bug reporter ("Help >> Report a Bug..." in the editor's main menu)?

    Is there anything interesting in the adb log? Just wondering if Unity is logging an error that may give a hint at what's happening here.